Bug 181594 - "Web" word is not translatable.
"Web" word is not translatable.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: i18n, StringChange
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-02-14 19:56 EST by Dawid Gajownik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: anaconda-11.1.0.86-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 05:56:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing this text (9.29 KB, image/png)
2006-02-14 19:56 EST, Dawid Gajownik
no flags Details

  None (edit)
Description Dawid Gajownik 2006-02-14 19:56:01 EST
Description of problem:
"Web" word is not translatable, because it's hardcoded in the source file:

[rpm-build@X anaconda-10.92.4]$ grep netServerPrompt -A 5 -r ./loader2/net.c
char *netServerPrompt = \
    N_("Please enter the following information:\n"
       "\n"
       "    o the name or IP number of your %s server\n"
       "    o the directory on that server containing\n"
       "      %s for your architecture\n");
[rpm-build@X anaconda-10.92.4]$ grep netServerPrompt -rn .
./loader2/nfsinstall.c:52:    buf = sdupprintf(_(netServerPrompt), "NFS",
getProductName());
./loader2/net.h:31:extern char *netServerPrompt;
./loader2/net.c:47:char *netServerPrompt = \
./loader2/urls.c:261:        buf = sdupprintf(_(netServerPrompt), "FTP",
getProductName());
./loader2/urls.c:266:        buf = sdupprintf(_(netServerPrompt), "Web",
getProductName());
[rpm-build@X anaconda-10.92.4]$

In Polish "Web" sounds strange a bit. It would be better to translate it to "WWW".

Version-Release number of selected component (if applicable):
anaconda-10.92.4-1

How reproducible:
Choose installation method via HTTP.
Comment 1 Dawid Gajownik 2006-02-14 19:56:01 EST
Created attachment 124662 [details]
screenshot showing this text
Comment 2 Jeremy Katz 2006-02-15 14:54:50 EST
This has been this way for years at this point.  We use web consistently in
other parts of the text, so for FC5, I think we're better off leaving it as-is
and doing a good fix for FC6.
Comment 3 A S Alam 2006-08-31 05:56:27 EDT
"Web" is changed to "WWW". so Bug is fixed. Tested with following version

anaconda-11.1.0.86-1

Note You need to log in before you can comment on or make changes to this bug.