Bug 181601 - firefox ssl still broken in enforcing mode
firefox ssl still broken in enforcing mode
Status: CLOSED DUPLICATE of bug 180726
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Depends On:
  Show dependency treegraph
Reported: 2006-02-14 22:42 EST by Dave Jones
Modified: 2015-01-04 17:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-14 23:52:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
firefox dialog on startup (14.00 KB, image/png)
2006-02-14 22:42 EST, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2006-02-14 22:42:03 EST
I though this got fixed a few weeks back.
I did a fresh install (not upgrade) of the latest tree, and tried starting
firefox, and got the attached dialog.

here's what ended up in dmesg..

audit(1139975061.034:105): avc:  denied  { execstack } for  pid=3276
comm="firefox-bin" scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process

Firefox then starts up, but SSL browsing is impossible.
Comment 1 Dave Jones 2006-02-14 22:42:03 EST
Created attachment 124664 [details]
firefox dialog on startup
Comment 2 Daniel Walsh 2006-02-14 23:17:48 EST
The question is why does firefox need execstack to do SSL Browsing?  Is this
really necessary or is this a problem in the library?  We can mask the problem
by allowing firefox execstack, but is that what we want?
Comment 3 Christopher Aillon 2006-02-14 23:52:58 EST

*** This bug has been marked as a duplicate of 180726 ***

Note You need to log in before you can comment on or make changes to this bug.