Bug 1816098 - blivet-gui fail to create a encrypted PV/VG partition
Summary: blivet-gui fail to create a encrypted PV/VG partition
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1819900 (view as bug list)
Depends On:
Blocks: F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-03-23 10:54 UTC by Dario Lesca
Modified: 2020-04-03 00:52 UTC (History)
14 users (show)

Fixed In Version: blivet-gui-2.1.13-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-03 00:52:49 UTC
Type: Bug


Attachments (Terms of Use)
error screenshot (101.12 KB, image/png)
2020-03-24 09:43 UTC, Kamil Páral
no flags Details

Description Dario Lesca 2020-03-23 10:54:15 UTC
Description of problem:
bliver-gui fail to create a encrypted PV/VG partition

Version-Release number of selected component (if applicable):
Fedora 32 Beta

How reproducible:

Steps to Reproduce:
1.Boot with Live Fedora 32 beta
2.run "sudo bliver-gui"
3.try to create a VG encrypted partition

Actual results:
bliver-gui crash with:
Traceback (most recent call last):
   File "/usr/lib/python3.8/site-packages/blivetgui/blivet_utils.py", 
line 1226, in add_device
     actions = add_function(self, user_input)
   File "/usr/lib/python3.8/site-packages/blivetgui/blivet_utils.py", 
line 1067, in _create_lvm
     pv_actions = self._create_lvmpv(pv_input)
   File "/usr/lib/python3.8/site-packages/blivetgui/blivet_utils.py", 
line 1012, in _create_lvmpv
     luks_version=user_input.encryption_type,
   File 
"/usr/lib/python3.8/site-packages/blivetgui/communication/proxy_utils.py", 
line 48, in __getattr__
     raise AttributeError("%s has no attribute %s" % 
("ProxyDataContainer", name))
AttributeError: ProxyDataContainer has no attribute encryption_type

Expected results:
bliver-gui not crash

Additional info:

Comment 1 Samuel Sieb 2020-03-23 18:28:43 UTC
I figured it out.  That's the wrong way to do it, but it definitely shouldn't crash and take out the installer.
I don't know if this should be a blocker, but it's likely to cause problems.

Comment 2 Kamil Páral 2020-03-24 09:42:05 UTC
I can reproduce this on F32 Beta Workstation Live inside Anaconda:

1. Go to Blivet partitioning
2. Select to add a partition
3. Select LVM2
4. Select Encrypt
5. Type in password
6. Click Create
7. See traceback

anaconda-32.24.2-3.fc32.x86_64
blivet-data-3.2.0-3.fc32.noarch
blivet-gui-runtime-2.1.12-1.fc32.noarch
python3-blivet-3.2.0-3.fc32.noarch

Proposing as a blocker:
"The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration. "
https://fedoraproject.org/wiki/Fedora_32_Final_Release_Criteria#Disk_layouts

Comment 3 Kamil Páral 2020-03-24 09:43:10 UTC
Created attachment 1672996 [details]
error screenshot

Comment 4 Vojtech Trefny 2020-03-25 08:48:48 UTC
upstream PR: https://github.com/storaged-project/blivet-gui/pull/163

As a temporary workaround you can create the PVs manually (first add encrypted partitions with filesystem "lvmpv") and after that add a LVM VG. Sorry for inconvenience and thank you for the report.

Comment 5 Geoffrey Marr 2020-03-30 18:57:25 UTC
Discussed during the 2020-03-30 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration."

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-30/f32-blocker-review.2020-03-30-16.00.txt

Comment 6 Vojtech Trefny 2020-04-02 05:44:29 UTC
*** Bug 1819900 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2020-04-02 10:40:48 UTC
FEDORA-2020-576bd54f42 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-576bd54f42

Comment 8 Kamil Páral 2020-04-02 12:05:09 UTC
(In reply to Fedora Update System from comment #7)
> FEDORA-2020-576bd54f42 has been submitted as an update to Fedora 32.
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-576bd54f42

The problem is fixed with this update.

Comment 9 Fedora Update System 2020-04-03 00:52:49 UTC
FEDORA-2020-576bd54f42 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.