Bug 181611 - editing file with character \x80 crashes
Summary: editing file with character \x80 crashes
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-15 13:36 UTC by Roland Bencsik
Modified: 2013-07-02 23:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 12:26:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roland Bencsik 2006-02-15 13:36:10 UTC
Description of problem:
Pressing enter just after an \x80 character in the editor causes Segmentation 
fault.

Version-Release number of selected component (if applicable):
Version     : 4.6.1a
Release     : 4.FC4

How reproducible:
Create a sample file with character \x80, 
open it in the editor and press enter after the \Ã80 character.

Steps to Reproduce:
1. perl -e 'print "text = \"\x80\";\n";' > sample
2. In mc press F4 on the sample file to edit.
3. Position to the second quotation mark and press enter.
  
Actual results:
Segmentation fault

Expected results:
The edited line should be broken into two lines.
The \x80 should be the last character of the original line
and with the second quotation mark a new line should be started.

Additional info:
Probably the problem is related to some UTF patch applied by Fedora developers 
(see the external bug reference link).

External Bug Reference:
  location: http://savannah.gnu.org
  bug id: #15712
  link: https://savannah.gnu.org/bugs/?func=detailitem&item_id=15712

Comment 1 Jindrich Novy 2006-02-15 15:07:27 UTC
I successfully reproduced it. This seems to be fixed by the latest rawhide mc,
so I'll release updates soon.

I'll close this after the update is released. Thanks.

Comment 2 Fedora Update System 2006-03-07 16:37:04 UTC
From User-Agent: XML-RPC

mc-4.6.1a-5.fc4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.