Bug 1816309 - CVE-2020-10684 ansible: code injection when using ansible_facts as a subkey [openstack-rdo]
Summary: CVE-2020-10684 ansible: code injection when using ansible_facts as a subkey [...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: distribution
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: trunk
Assignee: Alfredo Moralejo
QA Contact: Shai Revivo
URL:
Whiteboard: component:ansible
Depends On:
Blocks: CVE-2020-10684
TreeView+ depends on / blocked
 
Reported: 2020-03-23 19:04 UTC by Borja Tarraso
Modified: 2020-03-25 10:16 UTC (History)
13 users (show)

Fixed In Version: ansible-2.8.10-1.el7.ans
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-25 10:16:21 UTC


Attachments (Terms of Use)

Description Borja Tarraso 2020-03-23 19:04:10 UTC
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of openstack-rdo.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When submitting as an update, use the fedpkg template provided in the next
comment(s).  This will include the bug IDs of this tracking bug as well as
the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
fedpkg commit message.

Comment 1 Alfredo Moralejo 2020-03-25 10:16:21 UTC
Fixed by update to 2.8.10 in https://review.rdoproject.org/r/#/c/25967/ and https://review.rdoproject.org/r/#/c/26071/


Note You need to log in before you can comment on or make changes to this bug.