Bug 181631 - Firstboot fails to run when RHGB not installed
Firstboot fails to run when RHGB not installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-15 11:57 EST by G.Wolfe Woodbury
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 09:44:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2006-02-15 11:57:18 EST
Description of problem:
even with an extended timeout value (25 sec) firstboot fails to startup when
RHGB is *not* installed.

Version-Release number of selected component (if applicable):
firstboot-1.4.4-1

How reproducible:
always

Steps to Reproduce:
1. install rawhide excluding RHGB package
2.
3.
  
Actual results:
I increased the timeout in xfirstboot.py to 25 seconds to ruleout problems with
the Trident Cyberblade/i1 AGP card.  Firstboot comes up and displays the Welcome
screen, but clicking the "Forward" button causes firstboot to crash with a
report of "Cannot communicate with window manager"  (Don't have the
/tmp/firstboot-crash.txt for this, sorry)

Attempting to run firstboot from a root terminal window also fails with a
"Cannot start any firstboot interface" (or something like that) error.


Expected results:


Additional info:  similar problems with old bug, but now it comes up and fails
at the first mouse click.
Comment 1 G.Wolfe Woodbury 2006-02-21 11:16:34 EST
FC5t3: Firstboot seems to get its X config independently of the xorg.conf file.
This leads to a failure because rhpxl is finding the "wrong" card on my setup
(PCI before AGP - changed behaviour from t1 and t2)  and still won't start from
the command line.
Comment 2 Chris Lumens 2006-02-22 14:17:44 EST
rhpxl could probably be changed to allow use of the system X config file. 
anaconda also uses rhpxl to get the X configuration, so hopefully the anaconda
file and the firstboot file should be the same.  If not, that's a good reason to
make that change to rhpxl.

I think it's probably worth investigating just removing that timeout in
firstboot, too.  I've had some success with reproducing this problem, but it's
not regular.  Also, sometimes I'm getting the "Cannot communicate" message
spuriously.  I think that's probably doing more harm than good.
Comment 3 Chris Lumens 2006-02-24 15:49:43 EST
What's the status of this now with the rhpxl multihead changes that went in on 2/22?
Comment 4 G.Wolfe Woodbury 2006-02-24 17:57:08 EST
Attempted install today, anaconda bug #182990 prevents testing,
Comment 5 Chris Lumens 2006-03-02 10:36:45 EST
This should be better now.
Comment 6 G.Wolfe Woodbury 2006-03-05 18:22:36 EST
Tested a rawhide install 2006-03-03 and things went fine without rhgb in the mix.

Note You need to log in before you can comment on or make changes to this bug.