Bug 1816421 - Fedora startup failure after Kernel upgraded to 5.5.10
Summary: Fedora startup failure after Kernel upgraded to 5.5.10
Keywords:
Status: CLOSED DUPLICATE of bug 1815374
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-23 23:43 UTC by Roland Askew
Modified: 2020-03-26 12:41 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-26 12:41:00 UTC
Type: Bug


Attachments (Terms of Use)
kernel logs from booting with 5.5.10 (98.99 KB, text/plain)
2020-03-23 23:43 UTC, Roland Askew
no flags Details

Description Roland Askew 2020-03-23 23:43:53 UTC
Created attachment 1672857 [details]
kernel logs from booting with 5.5.10

After updating to Kernel 5.5.10, in Fedora 31, my laptop freezes during startup.

Laptop appears to start normally, shows laptop logo, then screen cuts out and occasionally flashes. No further progress is made in startup.

I have a second screen attached, when the laptop screen cuts out, the second screen shows the bootup sequence console. The sequence appears to go normally until a message about the "Plymouth Service", then it makes no further progress.


The previous working version is 5.5.8. I am currently using this version to boot.

I am not 100% sure how to reproduce the issue. It began after updating to 5.5.10. It could relate to having an older laptop (I have a Toshiba SatPro PT-50a, approx 2012).

There were some script errors during the DNF update / install, relating to the boot EFI, see the additional information below from the DNF history command.


I've had prior issues with screen cutout upon updating but forcing a soft reboot has fixed the problem. It is not fixing it this time, however. I've also had rare messages that the /boot/EFI logical partition was not mounting, although only after the laptop fully booted which suggested otherwise. the EFI "not mount" message has only occurred in the last 6 weeks.


Some additional info:

-------------------
$> sudo dnf history 

ID     | Command line             | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
...
   428 | update -y                | 2020-03-22 14:18 | E, I, U        |  362 EE
...

-------------------
$> sudo dnf history info 428

Transaction ID : 428
...
Return-Code    : Success
Releasever     : 31
Command Line   : update -y
Packages Altered:
    Install  kernel-5.5.10-200.fc31.x86_64                   @updates
    Install  kernel-core-5.5.10-200.fc31.x86_64              @updates
    Install  kernel-devel-5.5.10-200.fc31.x86_64             @updates
    Install  kernel-modules-5.5.10-200.fc31.x86_64           @updates
    Install  kernel-modules-extra-5.5.10-200.fc31.x86_64     @updates
...
< additional upgrades to grub2, some pheripheral firmware for wifi and ethernet, bluetooth, linux-firmware...>
...
    Upgrade  kernel-headers-5.5.9-200.fc31.x86_64            @updates
    Upgraded kernel-headers-5.5.8-200.fc31.x86_64            @@System
...
Scriptlet output:
   1 error: lsetfilecon: (/boot/efi/EFI/fedora, system_u:object_r:boot_t:s0) Operation not supported
   2 Redirecting to /bin/systemctl start atd.service
   3 error: lsetfilecon: (/boot/efi/EFI/fedora/fonts, system_u:object_r:boot_t:s0) Operation not supported
   4 error: lsetfilecon: (/boot/efi/EFI/fedora/grubia32.efi;5e76bd09, system_u:object_r:boot_t:s0) Operation not supported
   5 error: lsetfilecon: (/boot/efi/EFI/fedora/grubx64.efi;5e76bd09, system_u:object_r:boot_t:s0) Operation not supported
   6 error: lsetfilecon: (/boot/efi/EFI/fedora/fonts, system_u:object_r:boot_t:s0) Operation not supported
   7 error: lsetfilecon: (/boot/efi/EFI/fedora/fonts/unicode.pf2;5e76bd09, system_u:object_r:boot_t:s0) Operation not supported
   8 error: lsetfilecon: (/boot/efi/EFI/fedora/gcdia32.efi;5e76bd09, system_u:object_r:boot_t:s0) Operation not supported
   9 error: lsetfilecon: (/boot/efi/EFI/fedora/gcdx64.efi;5e76bd09, system_u:object_r:boot_t:s0) Operation not supported
  10 Warning: The unit file, source configuration file or drop-ins of cups.path changed on disk. Run 'systemctl daemon-reload' to reload units.
  11 Warning: The unit file, source configuration file or drop-ins of cups.socket changed on disk. Run 'systemctl daemon-reload' to reload units.
  12 Warning: The unit file, source configuration file or drop-ins of cups.service changed on disk. Run 'systemctl daemon-reload' to reload units.
  13 Job failed. See "journalctl -xe" for details.
  14 warning: file /lib/modules/5.5.5-200.fc31.x86_64/updates: remove failed: No such file or directory
  15 Warning: The unit file, source configuration file or drop-ins of bluetooth.service changed on disk. Run 'systemctl daemon-reload' to reload units.
  16 Warning: The unit file, source configuration file or drop-ins of mdmonitor.service changed on disk. Run 'systemctl daemon-reload' to reload units.
  17 dkms: running auto installation service for kernel 5.5.10-200.fc31.x86_64
  18  Done. 
  19 dkms: running auto installation service for kernel 5.5.10-200.fc31.x86_64
  20  Done. 

--------------

Comment 1 Hans de Goede 2020-03-24 09:56:55 UTC
This sounds like it might be a duplicate of bug 1815374.

Are you using and AMD/ATI gfx-card ?

Can you do:

sudo lsinitrd /boot/initramfs-5.5.10-200.fc31.x86_64.img > lsinitrd.txt

And then in the lsinitrd output look for firmware, then check if some if the firmware files are perhaps 0 bytes large? (note dirs are listed as being 0 bytes large, that is normal, but individual firmware files should not be 0 bytes.

If you have 0 byte sized firmware-files, downgrading dracut will probably work around this:

To downgrade, do:

1. "rpm -qa | grep dracut" and note which dracut packages you have installed
2. Go to: https://koji.fedoraproject.org/koji/buildinfo?buildID=1286558 and download the x86_64 version of the packages you have installed
3. From a dir with these packages run: "sudo rpm -Uvh --oldpackage dracut*.rpm"

And then regenerate the initrd for the 5.5.10 kernel with the downgraded dracut:

sudo dracut -f /boot/initramfs-5.5.10-200.fc31.x86_64.img 5.5.10-200.fc31.x86_64

After that, redo the lsinitrd and check if the 0 sized firmware files are fixed. If that is fixed try booting 5.5.10 again.

Comment 2 Roland Askew 2020-03-26 10:54:26 UTC
My laptop has an Nvidia card, using the nouveau firmware.

From the lsinitrd command, the following firmware files are zero-byte sized:

usr/lib/firmware/nvidia/gp102/gr/gpccs_inst.bin
usr/lib/firmware/nvidia/gp107/gr/fecs_bl.bin
usr/lib/firmware/nvidia/gp107/gr/gpccs_bl.bin
usr/lib/firmware/nvidia/gp107/gr/sw_ctx.bin
usr/lib/firmware/nvidia/gp107/gr/sw_nonctx.bin
usr/lib/firmware/nvidia/gp108/gr/gpccs_bl.bin




Additionally, while rechecking the problem, when the system clock rolled over past midnight last night (25 march, NZ timezone) it started booting properly - I rebooted into 5.5.10 around 11:50pm, let it run, then forced a shutdown and new boot at 12:03am, it showed the boot login slightly longer than usual, but reached login and is working. Problem has not reoccurred.

What is the best way to proceed? Would fixing the zero byte sized firmware files help?


The following dracut packages are installed, if helpful:

dracut-050-26.git20200316.fc31.x86_64
dracut-squash-050-26.git20200316.fc31.x86_64
dracut-live-050-26.git20200316.fc31.x86_64
dracut-config-rescue-050-26.git20200316.fc31.x86_64
dracut-network-050-26.git20200316.fc31.x86_64

Comment 3 Roland Askew 2020-03-26 10:57:57 UTC
Correction: 

- I rebooted into 5.5.10 around 11:50pm, let it run the boot, it continued to have the problem described.
- Then I forced a shutdown and new boot at 12:03am.
- It showed the toshiba boot logo slightly longer than usual. However it reached the fedora login screen, logging in worked, and fedora functioned normally.
- Doing a nominal shutdown, then booting, and doing a nominal reboot, both from the fedora menu, has not recreated the problem.

Comment 4 Hans de Goede 2020-03-26 12:41:00 UTC
Thank you for the status update.

According to bug 1815374 the 0 sized fw files also happen with dracut 049; and that seems to not be the cause.

Since this works for you now and since this being discussed in more detail in bug 1815374 I'm going to mark this one as a duplicate of that bug.

*** This bug has been marked as a duplicate of bug 1815374 ***


Note You need to log in before you can comment on or make changes to this bug.