Bug 1816476 - weird dependencies cause upgrade problems
Summary: weird dependencies cause upgrade problems
Keywords:
Status: CLOSED DUPLICATE of bug 1814716
Alias: None
Product: Fedora
Classification: Fedora
Component: polymake
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-24 04:54 UTC by Przemek Klosowski
Modified: 2020-03-24 14:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 14:52:23 UTC
Type: Bug


Attachments (Terms of Use)
yum update log (mutiple commands, see comment 2) (180.31 KB, text/plain)
2020-03-24 05:01 UTC, Przemek Klosowski
no flags Details

Description Przemek Klosowski 2020-03-24 04:54:27 UTC
Description of problem:
I believe polymake depends on weird packages that prevent smooth upgrade. I had to use --best --allowerasing, which deleted polymake; I then tried to reinstall polymake which caused a bunch of downgrades, including seemingly unrelated packages such as git, ocaml etc.

Version-Release number of selected component (if applicable):
polymake-3.5-4.fc31.x86_64 

How reproducible: tried this once


Steps to Reproduce:
1. yum update --best --allowerasing

Actual results: deleted polymake


Expected results: normal updates


Additional info:
As mentioned, plain yum update did not run because of requirement conflicts.

Comment 1 Przemek Klosowski 2020-03-24 05:01:45 UTC
Created attachment 1672902 [details]
yum update log (mutiple commands, see comment 2)

Comment 2 Przemek Klosowski 2020-03-24 05:02:36 UTC
I include a log of the yum session with the following commands:

$ sudo yum -y update                        # errors out
$ sudo yum -y update --best --allowerasing  # completes, deleting polymake
$ sudo yum -y install polymake              # this results in weird downgrades
$ sudo yum -y update --best --allowerasing  # doesn't change much, still downgraded packages
$ sudo yum erase polymake                   # sacrifice polymake to get newest git/perl/etc
$ sudo yum -y update --best --allowerasing  # this runs as expected

Comment 3 Jerry James 2020-03-24 14:52:23 UTC
Please see the explanation in bug 1814716.

*** This bug has been marked as a duplicate of bug 1814716 ***


Note You need to log in before you can comment on or make changes to this bug.