Bug 181657 - rhythmbox causes segfault in gstreamer
rhythmbox causes segfault in gstreamer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-02-15 13:54 EST by Dave Jones
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 18:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 332964 None None None Never

  None (edit)
Description Dave Jones 2006-02-15 13:54:41 EST
when I point rhythmbox at my oggs dir, it starts scanning files, and then..

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1084229968 (LWP 25858)]
0x00002ab19365880c in ?? () from
/usr/lib64/gstreamer-0.10/libgsttypefindfunctions.so
(gdb) bt
#0  0x00002ab19365880c in ?? () from
/usr/lib64/gstreamer-0.10/libgsttypefindfunctions.so
#1  0x0000003934a13230 in gst_type_find_helper () from
/usr/lib64/libgstbase-0.10.so.0
#2  0x00002ab19523a1be in gst_type_find_element_get_type () from
/usr/lib64/gstreamer-0.10/libgstcoreelements.so
#3  0x00000039357498ed in gst_pad_set_active () from
/usr/lib64/libgstreamer-0.10.so.0
#4  0x0000003935735673 in gst_element_release_request_pad () from
/usr/lib64/libgstreamer-0.10.so.0
#5  0x000000393573f0b3 in gst_iterator_fold () from
/usr/lib64/libgstreamer-0.10.so.0
#6  0x0000003935735145 in gst_element_release_request_pad () from
/usr/lib64/libgstreamer-0.10.so.0
#7  0x00000039357352ec in gst_element_release_request_pad () from
/usr/lib64/libgstreamer-0.10.so.0
#8  0x000000393573563c in gst_element_release_request_pad () from
/usr/lib64/libgstreamer-0.10.so.0
#9  0x00002ab19523a42c in gst_type_find_element_get_type () from
/usr/lib64/gstreamer-0.10/libgstcoreelements.so
#10 0x00000039357321c8 in gst_element_continue_state () from
/usr/lib64/libgstreamer-0.10.so.0
#11 0x0000003935734e39 in gst_element_release_request_pad () from
/usr/lib64/libgstreamer-0.10.so.0
#12 0x0000003935727f21 in gst_bin_add () from /usr/lib64/libgstreamer-0.10.so.0
#13 0x00000039357321c8 in gst_element_continue_state () from
/usr/lib64/libgstreamer-0.10.so.0
#14 0x0000003935734e39 in gst_element_release_request_pad () from
/usr/lib64/libgstreamer-0.10.so.0
#15 0x0000003935727f21 in gst_bin_add () from /usr/lib64/libgstreamer-0.10.so.0
#16 0x000000393574b61f in gst_pipeline_set_new_stream_time () from
/usr/lib64/libgstreamer-0.10.so.0
#17 0x00000039357321c8 in gst_element_continue_state () from
/usr/lib64/libgstreamer-0.10.so.0
#18 0x00000039357322ef in gst_element_continue_state () from
/usr/lib64/libgstreamer-0.10.so.0
#19 0x0000003935734e39 in gst_element_release_request_pad () from
/usr/lib64/libgstreamer-0.10.so.0
#20 0x000000000048033d in rb_metadata_load (md=0x2aaaab313e40,
    uri=0x2aaaab3e0e60
"file:///home/davej/Music/oggs/Depeche%20Mode/Remixes%2081-04%20(disc%201)/12%20-%20Just%20Can't%20Get%20Enough%20(Schizo%20mix).ogg",
error=0x2aaaab3fe120)
    at rb-metadata-gst.c:833
#21 0x000000000046525e in rhythmdb_execute_stat (db=0x85ec60,
    uri=0x2aaaaab88750
"file:///home/davej/Music/oggs/Depeche%20Mode/Remixes%2081-04%20(disc%201)/12%20-%20Just%20Can't%20Get%20Enough%20(Schizo%20mix).ogg",
event=0x2aaaab3fe100)
    at rhythmdb.c:1898
#22 0x00000000004654aa in action_thread_main (db=0x85ec60) at rhythmdb.c:2019
#23 0x000000392c342dc4 in g_thread_create_full () from /usr/lib64/libglib-2.0.so.0
#24 0x000000392f60618a in start_thread () from /lib64/libpthread.so.0
#25 0x000000392bacb67d in clone () from /lib64/libc.so.6
#26 0x0000000000000000 in ?? ()
Comment 1 Christopher Aillon 2006-02-16 13:23:48 EST
Dave, you're really good at not including version information in your bug
reports.  :-)
Comment 2 Dave Jones 2006-02-20 14:14:37 EST
rhythmbox-0.9.3.1-1.2
gstreamer-plugins-base-0.10.3-1
gstreamer-tools-0.10.3-3
gstreamer-plugins-good-0.10.2-1
gstreamer-0.10.3-3
Comment 3 Gordon Messmer 2006-03-10 01:43:31 EST
This problem was fixed in CVS:

http://bugzilla.gnome.org/show_bug.cgi?id=332964

It looks like we're too late for the final devel freeze, though.  Any chance
that an update will be available the day of FC5's release?
Comment 4 Ray Strode [halfline] 2006-03-10 10:14:26 EST
Potentially, let me put it on the FC5Update tracker.
Comment 5 John Thacker 2006-04-29 10:04:54 EDT
So if this was the fix mentioned above, shouldn't the released update
gstreamer-plugins-base-0.10.5-1 fix it?

Can you retest?
Comment 6 Dave Jones 2006-05-30 18:43:25 EDT
seems fixed.

Note You need to log in before you can comment on or make changes to this bug.