Bug 1816761 - in Wayland VM text is selected from line above pointer
Summary: in Wayland VM text is selected from line above pointer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-03-24 16:35 UTC by Jens Petersen
Modified: 2020-04-27 11:03 UTC (History)
12 users (show)

Fixed In Version: mutter-3.36.1-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-02 00:31:55 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/mutter - issues 1094 None None None 2020-03-25 15:04:35 UTC
GNOME Gitlab GNOME/mutter - merge_requests 1136 None None None 2020-03-24 16:35:58 UTC

Description Jens Petersen 2020-03-24 16:35:59 UTC
Description of problem:
In F32 GNOME text selection with the mouse is not taken from
below the pointer but the line above and a character to the left.

Version-Release number of selected component (if applicable):
mutter-3.36.0-1.fc32
mutter-3.36.0-2.fc32

How reproducible:
100%

Steps to Reproduce:
1. Try to select text with mouse in gnome-terminal or gedit

Actual results:
Selected text is highlighted from the line above pointer.

Expected results:
Text under the pointer to be selected.

Additional info:
This is being worked on upstream in https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1136

In my opinion this should be a F32 Blocker.

Workaround I believe is to use Xorg Gnome.

Comment 1 sandeep shedmake 2020-03-24 17:03:32 UTC
Yep, could reproduce the reported problem on a F32 WorkStation KVM box (post a week from 2020-03-10 I18N Test Day)

Comment 2 Jens Petersen 2020-03-25 05:17:14 UTC
I found the upstream links via this discussion on desktop list:
https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/thread/IGI7WS4JA24WGLNJU7OVTZCPH5HQ444U/

Comment 3 Adam Williamson 2020-03-25 15:03:31 UTC
Jens: you linked a PR. I linked an issue report. The issue report reports this same issue. The PR is the fix for it. There can be more than upstream link :)

Comment 4 Adam Williamson 2020-03-25 15:06:42 UTC
Note, I did a mutter build yesterday, but didn't include this PR as it is still under review upstream.

Comment 5 Fedora Blocker Bugs Application 2020-03-30 10:25:55 UTC
Proposed as a Blocker for 32-final by Fedora user jonha using the blocker tracking app because:

 The release must be able host virtual guest instances of the same release.

All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use.

Not fixing this would result in bad user experience when installing Fedora in a VM, for example resizing windows is awkward as the resize cursor is offset from the expected position, focusing textboxes inside the installer is also potentially problematic.

Comment 6 Geoffrey Marr 2020-03-30 19:13:43 UTC
Discussed during the 2020-03-30 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" and other desktop criteria when running in a VM using 'seamless mouse pointer' mode (which virt-manager and Boxes use by default).

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-30/f32-blocker-review.2020-03-30-16.00.txt

Comment 7 Fedora Update System 2020-04-01 17:05:08 UTC
FEDORA-2020-ed25e0cdcb has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-ed25e0cdcb

Comment 8 Adam Williamson 2020-04-01 17:06:03 UTC
I believe mutter 3.36.1 (included in the megaupdate) has the fix for this. Jens, can you confirm? Thanks!

Comment 9 Fedora Update System 2020-04-02 00:31:55 UTC
FEDORA-2020-ed25e0cdcb has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Jens Petersen 2020-04-02 03:40:08 UTC
Thanks a lot, Adam!

I think this issue already improved a bit with your earlier upstream patches (ie it fixed the line offset).

Sorry, I think I had misinterpreted https://gitlab.gnome.org/GNOME/mutter/-/issues/1094 as a different issue, apologies.
(Because I could only see the problem on text selection.)

Yep, with mutter-3.36.1 this looks completely fixed to me, awesome!
Thanks as always for going the extra mile on this one too.

Comment 11 Adam Williamson 2020-04-02 07:18:41 UTC
I really didn't do anything for the megaupdate, just tagged the bug! But thanks anyway :)

Comment 12 Kamil Páral 2020-04-02 11:45:17 UTC
I can confirm that this problem is fixed now.


Note You need to log in before you can comment on or make changes to this bug.