Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1816956 - Removing an attribute uniqueness does not ask for confirmation
Summary: Removing an attribute uniqueness does not ask for confirmation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: dirsrv-11.1
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-25 09:11 UTC by bsmejkal
Modified: 2020-04-29 08:04 UTC (History)
4 users (show)

Fixed In Version: 389-ds-base-1.4.2.11-1.module+el8dsrv+6254+69a018e7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-29 08:04:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1961 0 None None None 2020-04-29 08:04:49 UTC

Description bsmejkal 2020-03-25 09:11:54 UTC
Description of problem:
When deleting an attribute uniqueness, there is no confirmation if we really want to delete this entry. It just gets deleted.
This might pose a problem if you click on delete button accidentally.

Version-Release number of selected component (if applicable):
cockpit-389-ds-1.4.2.9-1.module+el8dsrv+6001+1cbc6dcf.noarch

How reproducible:
Always

Steps to Reproduce:
1. On the 'Plugins' tab click on 'Attribute Uniqueness'
2. Click on 'Add config' and create a custom attribute uniqueness (e.g. for telephonenumber)
3. Click the 'Actions' button next to the new attribute uniqueness
4. Select 'Delete Config'

Actual results:
Attribute uniqueness is deleted without asking.

Expected results:
A popup window should ask if we really want to proceed in Delete action.

Additional info:

Comment 3 bsmejkal 2020-04-17 14:07:25 UTC
Build tested:
389-ds-base-1.4.2.12-1.module+el8dsrv+6328+f04d7471.x86_64
cockpit-389-ds-1.4.2.12-1.module+el8dsrv+6328+f04d7471.noarch

A popup window now asks if we really want to delete created attribute uniqueness.
Marking as VERIFIED.

Comment 5 errata-xmlrpc 2020-04-29 08:04:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1961


Note You need to log in before you can comment on or make changes to this bug.