Bug 1817098 - Instance fails to start after creating attribute uniqueness because of a missing attribute
Summary: Instance fails to start after creating attribute uniqueness because of a miss...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: dirsrv-11.1
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-25 15:00 UTC by bsmejkal
Modified: 2020-04-29 08:04 UTC (History)
3 users (show)

Fixed In Version: 389-ds-base-1.4.2.11-1.module+el8dsrv+6254+69a018e7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-29 08:04:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1961 None None None 2020-04-29 08:04:49 UTC

Description bsmejkal 2020-03-25 15:00:46 UTC
Description of problem:
Instance fails to start after restart when creating an attribute uniqueness.
This is because the new entry is missing 'uniqueness-subtrees' attribute (subtree was correctly filled in webUI form).
Workaround is to manually create 'uniqueness-subtrees' : 'dc=example,dc=com' for 'cn=telephonenumber uniqueness,cn=plugins,cn=config' to make the instance start.

Version-Release number of selected component (if applicable):
cockpit-389-ds-1.4.2.9-1.module+el8dsrv+6001+1cbc6dcf.noarch

How reproducible:
Always

Steps to Reproduce:
1. On the 'Plugins' tab click on 'Attribute Uniqueness'
2. Click on 'Add config' and create a custom attribute uniqueness (e.g. for telephoneNumber)
3. Restart the instance

Actual results:
Instance fails to start.

Expected results:
Attribute 'uniqueness-subtrees' should be created and instance starts successfully.

Additional info:
[24/Mar/2020:09:07:15.314654140 -0400] - ERR - plugin_dependency_startall - Failed to start betxnpreoperation plugin telephonenumber uniqueness
[24/Mar/2020:09:07:15.384467419 -0400] - ERR - NSUniqueAttr - uniqueness_entry_to_config - Objectclass for subtree entries is not defined
[24/Mar/2020:09:07:15.388398325 -0400] - ERR - plugin_dependency_startall - Failed to start betxnpreoperation plugin telephone uniqueness
[24/Mar/2020:09:07:15.391326663 -0400] - ERR - NSUniqueAttr - uniqueness_entry_to_config - Objectclass for subtree entries is not defined
[24/Mar/2020:09:07:15.399010028 -0400] - ERR - plugin_dependency_startall - Failed to start betxnpreoperation plugin telephonenumber uniqueness
[24/Mar/2020:09:07:15.409427137 -0400] - ERR - plugin_dependency_startall - Failed to resolve plugin dependencies
[24/Mar/2020:09:07:15.413010024 -0400] - ERR - plugin_dependency_startall - betxnpreoperation plugin telephonenumber uniqueness is not started

Comment 3 bsmejkal 2020-04-17 14:21:17 UTC
Build tested:
389-ds-base-1.4.2.12-1.module+el8dsrv+6328+f04d7471.x86_64
cockpit-389-ds-1.4.2.12-1.module+el8dsrv+6328+f04d7471.noarch

Created attribute uniqueness is not missing the 'uniqueness-subtrees' attribute.
Instance starts correctly after restart.

Marking as VERIFIED.

Comment 5 errata-xmlrpc 2020-04-29 08:04:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1961


Note You need to log in before you can comment on or make changes to this bug.