Bug 1817104 - create_admin fails at step5 of octavia AllNodeDeploySteps due to ansible fact gathering being slow on controllers with lots of interfaces
Summary: create_admin fails at step5 of octavia AllNodeDeploySteps due to ansible fact...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Alex Schultz
QA Contact: David Rosenfeld
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-25 15:11 UTC by David Hill
Modified: 2020-09-11 15:58 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-common-8.7.1-17.el7ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-24 11:33:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1869018 None None None 2020-03-25 15:18:20 UTC
OpenStack gerrit 715208 None MERGED Disable fact gathering for create_admin 2020-11-23 04:05:19 UTC
Red Hat Knowledge Base (Solution) 4848951 None None None 2020-03-25 15:13:42 UTC
Red Hat Product Errata RHBA-2020:2718 None None None 2020-06-24 11:33:46 UTC

Description David Hill 2020-03-25 15:11:55 UTC
Description of problem:
create_admin fails at step5 of octavia AllNodeDeploySteps due to ansible fact gathering being slow on controllers with lots of interfaces

Version-Release number of selected component (if applicable):
All

How reproducible:
Always 

Steps to Reproduce:
1. Have lots of interface on controllers and have fact gathering last longer than 5 minutes
2.
3.

Actual results:
fails

Expected results:
succeeds

Additional info:

Comment 11 Jad Haj Yahya 2020-05-27 11:55:56 UTC
for i in $(seq 1 380); do ip tuntap add name dummy_tun$i mode tun; done
for i in $(seq 1 1274); do ip link add name dummy_br$i type bridge; done


Used the above to create lot of interfaces

Comment 14 errata-xmlrpc 2020-06-24 11:33:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2718


Note You need to log in before you can comment on or make changes to this bug.