Bug 1817109 - File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-CPAN-Meta-2.150010/t/parse-cpan-meta/*.t' has wrong interpreter '#!/usr/bin/perl'
Summary: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-CPAN-Meta-2.15001...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: perl-CPAN-Meta
Version: rh-perl530
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 3.5
Assignee: perl-maint-list
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-25 15:28 UTC by Martin Kyral
Modified: 2020-05-26 09:25 UTC (History)
1 user (show)

Fixed In Version: rh-perl530-perl-CPAN-Meta-2.150010-452.el7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 09:25:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:2259 None None None 2020-05-26 09:25:26 UTC

Description Martin Kyral 2020-03-25 15:28:10 UTC
Description of problem:
File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-CPAN-Meta-2.150010/t/parse-cpan-meta/02_api.t' has wrong interpreter '#!/usr/bin/perl'
File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-CPAN-Meta-2.150010/t/parse-cpan-meta/03_functions.t' has wrong interpreter '#!/usr/bin/perl'
File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-CPAN-Meta-2.150010/t/parse-cpan-meta/04_export.t' has wrong interpreter '#!/usr/bin/perl'
File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-CPAN-Meta-2.150010/t/parse-cpan-meta/05_errors.t' has wrong interpreter '#!/usr/bin/perl'

Generally, all the scripts shipped in a collection shall have shebangs pointing to the collection or using env.


Version-Release number of selected component (if applicable):
rh-perl530-perl-CPAN-Meta-2.150010-451.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Petr Pisar 2020-03-25 15:39:43 UTC
I confirm this issue. I will remove the shebangs because those tests are not executable.

Comment 3 Petr Pisar 2020-03-25 15:47:12 UTC
Acutally we already rewrite them, but all of them. I will correct the rewrite to apply to all of them.

Comment 9 errata-xmlrpc 2020-05-26 09:25:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2259


Note You need to log in before you can comment on or make changes to this bug.