Bug 1817145 - oc adm release new image error not clear
Summary: oc adm release new image error not clear
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Sally
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-25 16:56 UTC by Stefan Schimanski
Modified: 2020-10-27 15:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:56:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 463 0 None closed Bug 1817145: Improve 'oc adm release info|new' error when given release image does not exist 2020-10-22 16:13:53 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:56:56 UTC

Description Stefan Schimanski 2020-03-25 16:56:49 UTC
Description of problem:

oc adm release new --from-release=registry.svc.ci.openshift.org/ocp/release:4.5.0-0.ci hyperkube=docker.io/sttts/origin-origin:dev --to-image sttts/origin-release:dev --allow-missing-images

tells me:

  error: image does not exist

Which image is not found? There are multiple in the command line.

Version-Release number of selected component (if applicable):

  master

How reproducible:

always.

Actual results:

  error: image does not exist

Expected results:

  error: image "registry.svc.ci.openshift.org/ocp/release:4.5.0-0.ci" not found

Additional info:

Comment 1 Stefan Schimanski 2020-03-25 17:00:13 UTC
And similarly, when the source image is found, but something breaks later, maybe because pull credentials are wrong?

  error: errors:
  denied: requested access to the resource is denied
  unauthorized: authentication required

Which access to which server is denied?

Comment 2 Michal Fojtik 2020-05-12 10:32:21 UTC
This bug hasn't had any activity in the last 30 days. Maybe the problem got resolved, was a duplicate of something else, or became less pressing for some reason - or maybe it's still relevant but just hasn't been looked at yet.

As such, we're marking this bug as "LifecycleStale" and decreasing severity from "medium" to "low".

If you have further information on the current state of the bug, please update it, otherwise this bug will be automatically closed in 7 days. The information can be, for example, that the problem still occurs, that you still want the feature, that more information is needed, or that the bug is (for whatever reason) no longer relevant.

Comment 3 Stefan Schimanski 2020-05-18 11:46:07 UTC
Unfreeze.

Comment 4 Sally 2020-05-20 16:26:23 UTC
Iā€™m adding UpcomingSprint, because I was occupied by fixing bugs with higher priority/severity, developing new features with higher priority, or developing new features to improve stability at a macro level. I will revisit this bug next sprint.

Comment 5 Sally 2020-06-18 14:27:19 UTC
Waiting on CI to merge openshift oc pull 463, that will resolve this bug.

Comment 8 zhou ying 2020-06-23 06:45:19 UTC
[root@dhcp-140-138 cli]# oc adm release new --from-release=registry.svc.ci.openshift.org/ocp/release:4.5.0-0.ci hyperkube=docker.io/sttts/origin-origin:dev --to-image sttts/origin-release:dev --allow-missing-images
error: image "registry.svc.ci.openshift.org/ocp/release:4.5.0-0.ci" does not exist

[root@dhcp-140-138 cli]# oc version --client -o yaml
clientVersion:
  buildDate: "2020-06-22T17:36:51Z"
  compiler: gc
  gitCommit: b644a4b43e8d1cd9fa003e7686ce19454f456d08
  gitTreeState: clean
  gitVersion: 4.6.0-202006221729.p0-b644a4b
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

Comment 10 errata-xmlrpc 2020-10-27 15:56:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.