Bug 1817174 - [4.4] Fix the kubelet configuration runtimeCgroups
Summary: [4.4] Fix the kubelet configuration runtimeCgroups
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Ryan Phillips
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On: 1817173
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-25 17:57 UTC by Ryan Phillips
Modified: 2020-05-04 11:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1817173
Environment:
Last Closed: 2020-05-04 11:47:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1583 None closed [release-4.4] Bug 1817174: Move non-existant runtimeCgroups kubelet option to flag 2020-07-23 16:45:59 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:47:44 UTC

Description Ryan Phillips 2020-03-25 17:57:53 UTC
+++ This bug was initially created as a clone of Bug #1817173 +++

Description of problem:
While debugging the 1.18 rebase Stefan found:

Mar 25 07:17:51 ip-10-0-158-139 hyperkube[1300]: W0325 07:17:51.773950    1300 codec.go:118] using lenient decoding as strict decoding failed: strict decoder error for kind: KubeletConfiguration
Mar 25 07:17:51 ip-10-0-158-139 hyperkube[1300]: : v1beta1.KubeletConfiguration.SerializeImagePulls: ReadObject: found unknown field: runtimeCgroups, error found in #10 byte of ...|meCgroups":"/system.|..., bigger context ...|ds":250,"ro>

This is a serialization issue, and a misconfiguration in:

https://github.com/openshift/machine-config-operator/pull/1540/files

Version-Release number of selected component (if applicable):
4.5 and 4.4

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Ryan Phillips 2020-03-30 19:03:34 UTC
I pinged Sunil on slack to verify the parent BZ.

Comment 3 Ryan Phillips 2020-03-30 21:28:45 UTC
Parent PR verified by QE.

Comment 8 errata-xmlrpc 2020-05-04 11:47:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.