Bug 1817175 - [4.4.z] buildah is not expanding env vars in file paths
Summary: [4.4.z] buildah is not expanding env vars in file paths
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.z
Assignee: Tom Sweeney
QA Contact: wewang
URL:
Whiteboard:
Depends On: 1810174
Blocks: 1810069 1822207
TreeView+ depends on / blocked
 
Reported: 2020-03-25 17:59 UTC by Adam Kaplan
Modified: 2020-06-25 12:20 UTC (History)
11 users (show)

Fixed In Version: buildah-1.11.6-6.rhaos4.4.el8
Doc Type: Bug Fix
Doc Text:
Cause: A code change inadvertently removed variables set by the 'ENV' statement in a Dockerfile from the internal list of variables to use when later resolving variable arguments in the Dockerfile. Consequence: Variables defined in a Dockerfile like 'ENV VERSION=0.0.1' would not later resolve in statements like 'COPY file-${VERSION}.txt /'. In this second statement, the '${VERSION}' variable resolved to a blank string ("") rather than "0.0.1" as it should have. Fix: The code was updated to also add variables defined by the ENV statement into the internal list of variables. Result: 'ENV' statements now resolve as intended.
Clone Of: 1810174
Environment:
Last Closed: 2020-05-18 13:35:02 UTC
Target Upstream Version:
adam.kaplan: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift builder pull 144 None closed Bug 1817175: bump github.com/containers/buildah and dependencies 2020-06-25 12:19:01 UTC
Red Hat Product Errata RHBA-2020:2133 None None None 2020-05-18 13:35:29 UTC

Comment 15 Tom Sweeney 2020-05-12 13:11:23 UTC
Added Documentation text

Comment 17 errata-xmlrpc 2020-05-18 13:35:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2133


Note You need to log in before you can comment on or make changes to this bug.