Bug 18172 - (savage) Diamond Stealth III S540 inoperable
(savage) Diamond Stealth III S540 inoperable
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 23:26 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 10:35:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-02 23:26:00 EDT
The above mentioned video card does not function under 7.0, but does 
function perfectly under 6.2  The screen is not drawn correctly.  Images 
do strange things when dragged.  Don't know how to describe it except to 
tell you to plug a card in and fire up the graphical installer (it fails 
there to).  This may be duplicate because the chipset is the Savage 4, but 
I can definitely say that the card doesn't work in 7, but did in 6.2
Comment 1 Need Real Name 2000-10-22 21:13:58 EDT
I have a Diamond A90 and have the same problems.  It worked fine under 6.2 but
is inoperable under 7.0.

Comment 2 Johnray Fuller 2000-12-13 13:35:21 EST
Please refer to the following link for a workaround for these cards (a Savage 4
based card):

http://www.redhat.com/support/docs/gotchas/7.0/gotchas-7-4.html#ss4.7

Johnray
Comment 3 Need Real Name 2001-03-09 10:35:06 EST
I found the exact same thing. The screen became usable by turning off the
accelaration
using the option noaccel in the XF86Config file. Performance was abysmal. Only
after
checking the gotchas on the RH support page, did I see the suggestion to
downgrade
the X server to the one used in RH6.2, which I did. I had been using RH6.1, so I
actually
found the RH6.2 XF86_SVGA X server to be an improvement over the 6.1 server,
whatever
it was. This seems to work for me, but I'm not sure if the RH6.2 XF86_SVGA
server uses
all of the capabilities of the Savage 4. So far I've had no problems.
Comment 4 Mike A. Harris 2001-03-18 18:22:05 EST
There is a brand new Savage driver in our XFree86 4.0.3 package.  This
driver is not included with the stock XFree86 distribution, but rather
is one that I found online from the savage maintainer.  I believe if you
upgrade to 4.0.3-1 you will have much better results.  You will also need
to upgrade to Mesa 3.4-13 as well, and may need to update Xconfigurator
also, or use one of the other config utils such as xf86cfg.

This new driver has a LOT better support for this family of cards.
Please try out my new release and if it does not work better for you please
open a new bug report.  Hope this works for ya!

Note You need to log in before you can comment on or make changes to this bug.