This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 181730 - Current FC BIND package does not correctly create the "named" user
Current FC BIND package does not correctly create the "named" user
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-15 20:13 EST by Max Kanat-Alexander
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 11:09:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Yum Log of first BIND installation (3.25 KB, text/plain)
2006-02-15 20:13 EST, Max Kanat-Alexander
no flags Details

  None (edit)
Description Max Kanat-Alexander 2006-02-15 20:13:10 EST
Version/Release: bind-9.3.1-14_FC4

I installed bind-chroot with yum, which also pulled in the "bind" package. (I
already had bind-libs installed, since I already had bind-utils installed.)

During the installation, it gave me a lot of warnings that the "named" user did
not exist.

After the installation, I tried "id named" and got "id: named: No such user".

I looked at the files in /var/named, and they were owned by the "root" user and
the "named" group.

I did an "rpm -e bind bind-chroot". I also did an "rm -rf /var/named; rm -f
/etc/sysconfig/named*; /etc/rndc*"

Then I did "yum install bind-chroot" again. This time it succeeded with no
errors, and the /var/named/* files are correctly owned by named:named.

I'm attaching the log of the first time I tried to install and got the warnings.
Comment 1 Max Kanat-Alexander 2006-02-15 20:13:10 EST
Created attachment 124729 [details]
Yum Log of first BIND installation
Comment 2 Jason Vas Dias 2006-03-07 11:09:29 EST
This problem could have potentially occurred if some other group had the gid 25
before bind was installed - then the named group would not have been created,
and the named user would not have been created.
This is now fixed with bind-9.3.2-6 in Rawhide / FC-5 .
 
Comment 3 Jason Vas Dias 2006-03-07 11:25:14 EST
Also fixed with bind-9.3.1-16.FC4, to be released to FC-4 updates/testing today.
Comment 4 Fedora Update System 2006-03-07 23:43:36 EST
From User-Agent: XML-RPC

bind-9.3.1-16_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Jason Vas Dias 2006-03-20 14:37:37 EST
All attempts to fix this bug are dis-allowed by our packaging policy.
Apparently, if your system disallows named user or group creation by
the bind package, then your system is in an invalid and unsupported
state .

Note You need to log in before you can comment on or make changes to this bug.