Bug 1817316 - Descheduler only honors short hand strategy names
Summary: Descheduler only honors short hand strategy names
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Mike Dame
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1817318
TreeView+ depends on / blocked
 
Reported: 2020-03-26 06:17 UTC by RamaKasturi
Modified: 2020-06-16 12:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Technology Preview
Doc Text:
Package(s) providing the Technology Preview: Descheduler Description of the Technology Preview: Descheduler Operator now supports full upstream Descheduler strategy names (for more 1-to-1 config)
Clone Of:
: 1817318 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:47:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:48:13 UTC

Description RamaKasturi 2020-03-26 06:17:15 UTC
Description of problem:
I see that the descheduler only honors short hand strategy names like duplicates, interpodaffinity, nodetaints etc where as it should also honor strategies "RemoveDuplicates" , RemovePodsViolatingInterPodAntiAffinity etc.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-03-24-101858

How reproducible:
Always

Steps to Reproduce:
1. Install descheduler operator
2. Now set the strategy as "RemoveDuplicates"
3.

Actual results:
Descheduler does not create any kubedescheduler cluster object with this strategy and it gives below error.
and error is seen in the operator logs E0324 16:12:46.123566       1 target_config_reconciler.go:297] key failed with : expected one of the duplicates,interpodantiaffinity,lownodeutilization,nodeaffinity,nodetaints to be enabled but found following invalid strategies RemoveDuplicates

Expected results:
Descheduler should honor the startegy name "RemoveDuplicates"

Additional info:

Comment 5 Mike Dame 2020-03-27 14:08:10 UTC
Switching this to 4.5, please verify it against master with a manual deployment (these steps should be sufficient now: https://github.com/openshift/cluster-kube-descheduler-operator#quick-development, no need to go through the index image method if you don't want to)

That will allow https://bugzilla.redhat.com/show_bug.cgi?id=1817318 to be backported to 4.4 in https://github.com/openshift/cluster-kube-descheduler-operator/pull/104

Comment 9 errata-xmlrpc 2020-05-04 11:47:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.