Bug 1817330 - Firefox cannot open mailto links
Summary: Firefox cannot open mailto links
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-26 07:01 UTC by Pierre Ossman
Modified: 2020-06-02 16:26 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-17 02:42:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Pierre Ossman 2020-03-26 07:01:47 UTC
Firefox has suddenly stopped being able to open mailto: links. It still invokes thunderbird, but thunderbird only pops up a dialog stating that an instance of thunderbird is already running. It works fine using "xdg-open mailto:foo@example.com" though, so it seems to be a bug in Firefox rather than thunderbird.

I've fully updates the system and restarted it without any improvement.

I seem to recall this has happened before and had something to do with Firefox messing with temp directories or environment variables pointing to them.

firefox-74.0-3.fc31.x86_64
thunderbird-68.6.0-1.fc31.x86_64

Comment 1 Martin Stransky 2020-03-26 07:04:43 UTC
Jan. can you look at it please?
Thanks.

Comment 2 Dmitry Burstein 2020-04-06 01:35:15 UTC
Can confirm the same on F32 beta with:

firefox-74.0.1-1.fc32.x86_64
thunderbird-68.6.0-1.fc32.x86_64

Comment 3 Dmitry Burstein 2020-04-19 17:35:27 UTC
Can confirm also with firefox-75.0-1.fc33.x86_64

Comment 4 Jan Horak 2020-04-20 08:41:13 UTC
Yes, I can see it too. The problem is that the thunderbird is launched with the same environment as Firefox, which has MOZ_ENABLE_WAYLAND=1 set under wayland, so if there's already thunderbird running in xorg backend it fails to start stating that an instance of thunderbird is already running.

Comment 5 heavy 2020-04-29 18:22:47 UTC
I actually came to report this bug too. It has actually been prevalent for me since at least Fedora 31, but it may have started in Fedora 30, I'm not sure. It did work at one time. I didn't experience this with "mailto" links, but rather by clicking on "Email Link..." in Firefox, which results in the same error. I use this feature a lot and have been hoping for a fix for a while now, but after upgrading to Fedora 32 and having the same bug, I finally got motivated to search and/or post a bug report. So, here I am. Thanks for looking into it.

Comment 6 info 2020-05-15 10:31:44 UTC
Can confirm this too. on FC31 and FC32

firefox-76.0.1-1.fc32.x86_64
thunderbird-68.7.0-1.fc32.x86_64

Comment 7 Martin Stransky 2020-05-15 10:37:14 UTC
I'll look at it, we need to backport https://bugzilla.mozilla.org/show_bug.cgi?id=1609134 to TB too.

Comment 8 Fedora Update System 2020-05-15 15:23:22 UTC
FEDORA-2020-002b923d05 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-002b923d05

Comment 9 Fedora Update System 2020-05-15 15:23:23 UTC
FEDORA-2020-f5e68512a7 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f5e68512a7

Comment 10 Fedora Update System 2020-05-15 15:23:23 UTC
FEDORA-2020-7fd99ffae0 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7fd99ffae0

Comment 11 Fedora Update System 2020-05-16 04:44:25 UTC
FEDORA-2020-002b923d05 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-002b923d05`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-002b923d05

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2020-05-16 05:07:05 UTC
FEDORA-2020-f5e68512a7 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f5e68512a7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f5e68512a7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2020-05-16 05:42:07 UTC
FEDORA-2020-7fd99ffae0 has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-7fd99ffae0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7fd99ffae0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-05-17 02:42:34 UTC
FEDORA-2020-f5e68512a7 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2020-05-17 03:48:48 UTC
FEDORA-2020-002b923d05 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 heavy 2020-05-18 14:37:33 UTC
I just updated my Fedora 32 workstation and was able to successfully perform an "Email Link..." from Firefox to Thunderbird, so this appears to have fixed the issue for me. Thanks!


Note You need to log in before you can comment on or make changes to this bug.