Bug 181739 - firewire disk requires `expert', but usb disk doesn't?!?
firewire disk requires `expert', but usb disk doesn't?!?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-15 23:41 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 17:57:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-15 23:41:56 EST
Description of problem:
In order to install to a disk connected through a Firewire interface, I have to
add `expert' to the installer boot command line, but in order to install to the
same disk connected through its USB interface, I don't have to.  Is that on
purpose?  Could the need for `expert' be lifted for Firewire disks, at least
when searching for existing partitions, RAID devices and/or logical volumes?

Version-Release number of selected component (if applicable):
anaconda-10.92.4-1

How reproducible:
Every time

Steps to Reproduce:
1.Boot up the installer with a disk connected to USB
2.Proceed to the disk druid screen
3.Try again with the same disk connected to Firewire
4.Try again, but now with `expert' in the boot cmd line
  
Actual results:
The disk is usable in 2. and 4., but not in 3.

Expected results:
Should be usable in 3. as well, or in none of them.

Additional info:
The sbp2 module is loaded by the loader regardless of `expert', so that's not it.
Comment 1 Jeremy Katz 2006-02-15 23:45:37 EST
Both should be requiring 'expert' since boot loaders with either are a little
iffy at best.  Can you attach /tmp/scsidisks from the installer?
Comment 2 Alexandre Oliva 2006-02-16 05:17:03 EST
/tmp/scsidisks does not mention the disk at all when it is connected through the
USB port (?!?), but it correctly mentions the disk is on sbp2 when it is
connected through the Firewire port.
Comment 3 Jeremy Katz 2006-02-20 15:29:06 EST
David -- can you take a look at this.
Comment 4 Jeremy Katz 2006-03-07 17:57:50 EST
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.