Bug 181743 - interactive ks install won't reboot automatically at the end
interactive ks install won't reboot automatically at the end
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-15 23:58 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 14:53:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-15 23:58:55 EST
Description of problem:
Even though my ks file contains the `reboot' directive, an interactive kickstart
install that uses this file will not reboot when the installation is complete;
it will rather wait for me to click on reboot, which is quite inconvenient and
unexpected.  I'm not sure whether this is because it was interactive or if
ignoring `reboot' is new for all kickstart installs; I'll give a non-interactive
install a try later.

Version-Release number of selected component (if applicable):
anaconda-10.92.4-1

How reproducible:
Every time

Steps to Reproduce:
1.Create a kickstart file with `reboot' and `kickstart' directives
2.Perform an kickstart install
  
Actual results:
When the install is complete, it displays the `installation is complete' screen
and waits for a mouse click before rebooting.

Expected results:
It should reboot as soon as it's done, as requested in the ks file.

Additional info:
Comment 1 Chris Lumens 2006-02-16 11:08:30 EST
Non-interactive installs do reboot (they even shutdown, etc).  Do you remember
what the old behavior for this situation is?
Comment 2 Alexandre Oliva 2006-02-16 13:35:12 EST
No, I haven't needed to do interactive ks installs in a long time.  It doesn't
sound right to not reboot, though.  How would you justify that?
Comment 3 Chris Lumens 2006-02-16 13:38:41 EST
I'd justify it by saying that since you're in an interactive install, you've had
to confirm every other setting by clicking something.  For instance, you now
have to click on the confirmation screen.  Even though the UI has been filled in
with the data provided by kickstart, you still have to confirm.  It's pretty
shaky justification and I don't feel strongly about it either way which is why
I'm inclined to just make sure it works the way it used to.
Comment 4 Alexandre Oliva 2006-02-17 14:24:37 EST
I think of `interactive' as `let me make sure it got the ks settings right',
rather than `do that and disregard some of the settings such as reboot' :-)

If I didn't want it to automatically reboot at the end, I might as well comment
out the `reboot' directive.  Requiring additional interaction at that point is
painfully disruptive, since it requires physical access to the box, potentially
a long time after installation started.

Since there's an easy way to get a prompt for the reboot if you want (take out
the reboot directive), and there isn't any way to enable automated reboot if
interactive implies there's going to be a prompt, I vote for interactive to not
disregard the reboot directive, even if that is a change in behavior.

Does this sounds like reasonable reasoning to you? :-)
Comment 5 Chris Lumens 2006-02-17 14:53:19 EST
Yes, that sounds reasonable.

Note You need to log in before you can comment on or make changes to this bug.