Bug 1817549 - Virtual Scroll (Events on Dashboard) is inaccessible by screen reader
Summary: Virtual Scroll (Events on Dashboard) is inaccessible by screen reader
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Steve Goodwin
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-26 14:47 UTC by Jessie
Modified: 2020-07-13 17:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:23:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
Event Activity on Dashboard Error (274.86 KB, image/png)
2020-03-26 14:47 UTC, Jessie
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4851 0 None closed Bug 1817549: Virtual Scroll (Events on Dashboard) is inaccessible by screen reader 2020-06-23 09:37:35 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:24:15 UTC

Description Jessie 2020-03-26 14:47:37 UTC
Created attachment 1673816 [details]
Event Activity on Dashboard Error

Description of problem:
When on the dashboard, the events activity grid isn't accessible by screen reader (particularly tested with Voice Over). It is read as "grid 0 columns 0 rows" and the user is unable to get into the grid. This error was noticed through axe testing, the error looks as follows: 

[
  {
    "data": [
      "row"
    ],
    "id": "aria-required-children",
    "impact": "critical",
    "message": "Required ARIA child role not present: row",
    "relatedNodes": [
      {
        "html": "<div class="ReactVirtualized__Grid__innerScrollContainer" role="rowgroup" style="width: auto; height: 22643px; max-width: 898px; max-height: 22643px; overflow: hidden; position: relative;">"
      }
    ]
  }
]

Version-Release number of selected component (if applicable):


How reproducible:
You can see this error by using the Axe Chrome Extension. 

Steps to Reproduce:
1. Inspect the page,
2. Click on the axe tab
3. Click "Analyze" - this issue is the one that says, "Certain ARIA roles must contain particular children"

Alternatively, you can open up VO by pressing command and F5, press control, option, and U to open the rotor, use the arrow left and right keys to get to the table menu, find the grid, then try to navigate into the grid (you can get into an item by pressing control, option, shift, and down arrow then navigate by control, option, right and left arrow).

Actual results:
An activity scroll that is inaccessible by screen reader.

Expected results:
To be able to navigate and understand the event activity grid through screen reader.

Additional info:

Comment 3 shahan 2020-03-31 04:03:54 UTC
Add the Axe Chrome Extension, analyze the page, did not find the error "Certain ARIA roles must contain particular children "anymore.

4.5.0-0.ci-2020-03-31-022827

Comment 5 errata-xmlrpc 2020-07-13 17:23:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.