This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 181761 - Inspiron 510m: Cannot install, screen only partially visible
Inspiron 510m: Cannot install, screen only partially visible
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On: 179714
Blocks: FC6Target FC5Update
  Show dependency treegraph
 
Reported: 2006-02-16 06:02 EST by Richard Körber
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 13:45:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (3.20 KB, text/plain)
2006-03-03 01:41 EST, Richard Körber
no flags Details
Xorg.0.log (53.50 KB, text/plain)
2006-03-03 01:43 EST, Richard Körber
no flags Details
Xorg.0.log of FC4 (66.89 KB, text/plain)
2006-03-07 10:47 EST, Richard Körber
no flags Details

  None (edit)
Description Richard Körber 2006-02-16 06:02:24 EST
I have tried to install FC5test2 on a Dell Inspiron 510m, but I failed at the
very beginning.

When I choose the graphical installer, only the upper left part of the display
is actually shown. When the mouse reaches the screen corners, nothing happens
(i.e. no scrolling). All buttons ("Next" etc.) are invisible and also not
reachable with the mouse. I could only use keyboard shortcuts to continue the
installation.

When trying to use the textual installer, the text is readable, but the layout
is garbled. The layout is getting worse on every keypress.

I can always reproduce it here, just by booting from the FC5test2 installer CD
#1 on a Dell Inspiron 510m.

Trying to install from the FC4 graphical installer does work fine. The screen is
completely visible.

I have noticed that the FC4 installer detected an "i852" video card, but
FC5test2 detected an "Intel 82852/855GM Integrated Graphics Device". The monitor
was both times detected as "unknown".
Comment 1 William Shotts 2006-02-18 18:59:22 EST
I see the same behavior on my circa 2004 Dell Dimension with i810 integrated
graphics.  Anaconda also fails to configure X (sets machine to run level 3
rather than 5 and no xorg.conf file is created) at all if a text install is
performed.  I am current to today's rawhide.
Comment 2 Rahul Sundaram 2006-02-20 05:48:15 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Jeremy Katz 2006-02-20 15:36:41 EST
Is this better with test3?

Does it help if you add resolution= to your boot command line and pass the
native resolution of your LCD?
Comment 4 Richard Körber 2006-02-21 01:36:48 EST
Tested with FC5test3, but nothing changed. Still only the left upper part of the
screen is visible, and the text installer layout is also still broken.

Booting with "linux resolution=1400x1050" had no effect at all. Was this the
right way to pass the resolution option?
Comment 5 Jeremy Katz 2006-02-21 10:48:19 EST
Yes, that's the right way.  If you do a text mode or VNC install, does X come up
properly after the installation?
Comment 6 Richard Körber 2006-02-22 03:33:43 EST
With VNC I was able to successfully install FC5test3 on that machine.

Anyhow I was unable to boot the machine after that, due to Bug 179714. I
currently have no way to find out if X was properly configured.

Using the rescue system, I could at least find out that /etc/inittab is
configured to start at runlevel 5. There is an /etc/X11/xorg.conf file present.
It is configured to use "i810" as video driver. The only configured screen mode
is 800x600, though, which is wrong. It's a 1400x1050 display.

Sorry, I have to give up at this point.
Comment 7 Mike A. Harris 2006-02-22 20:47:23 EST
Sounds like a video driver or X server problem, however we need the X
server log file and config file in order to diagnose.  Since you're unable
to boot due to bug #179714, I've added that bug as a blocker of this bug
for the time being.

Once you're able to boot FC5test3 with a new kernel or whatever is needed,
please boot into runlevel 3, and try "startx".  Update the report with
your findings, and if the problem you were experiencing is still present,
attach the X server log and config file to the report and we'll review
them.

Thanks in advance.

Comment 8 Richard Körber 2006-03-03 01:39:37 EST
Meanwhile there is a workaround for bug 179714. So I booted FC5test3 for the
first time. The first time setup configuration screen opened. It was shown in a
lower than the native resolution, but it was completely visible, no hidden
parts. I configured the monitor as a generic TFT with 1400x1050 resolution, set
up X to use this resolution with millions of colors, and finished the first time
setup.

Anyhow, GDM and also Gnome still appear in a lower resolution, I guess 1024x768.

system-config-display shows that X is set up correctly (1400x1050). When I open
the user's resolution preferences (is it "xrandr" ?), only the resolutions
640x480, 800x600 and 1024x768 are offered though, with the last one being selected.

I currently see no way to change to the display's native resolution. Anything
seems to be configured correctly so far.
Comment 9 Richard Körber 2006-03-03 01:41:21 EST
Created attachment 125583 [details]
xorg.conf
Comment 10 Richard Körber 2006-03-03 01:43:58 EST
Created attachment 125584 [details]
Xorg.0.log
Comment 11 Mike A. Harris 2006-03-06 20:14:40 EST
(II) I810(0): Not using mode "1400x1050" (no mode of this name)
(II) I810(0): Not using mode "1280x960" (no mode of this name)
(II) I810(0): Not using mode "1152x864" (no mode of this name)

Your video BIOS does not know those modes, so they are not available to the
X driver, which relies on VBE to set the video mode.  In order to work around
this hardware limitation, you'll need to use the i810resolution or similar
utilities floating around the net, until Intel provides the documentation to
X.Org developers to be able to program the mode timings directly to the hardware
instead of relying on the BIOS.

Alternatively, check your manufacturers website to see if they have released
an updated video BIOS for your motherboard, which has the native panel modes
built into it.
Comment 12 Richard Körber 2006-03-07 00:49:58 EST
Sorry, but I think the bug has been closed too early.

The original issue was that FC5test3 could not be installed because only parts
of the screen are visible, while other parts were hidden. If I understand it
right, there is still a valid 1024x768 resolution available, which could be used
by Anaconda for the graphical installation.
Comment 13 Mike A. Harris 2006-03-07 03:22:08 EST
>Trying to install from the FC4 graphical installer does work fine. The screen is
>completely visible.

I missed that in my previous review.

(In reply to comment #12)
> Sorry, but I think the bug has been closed too early.
> 
> The original issue was that FC5test3 could not be installed because only parts
> of the screen are visible, while other parts were hidden. If I understand it
> right, there is still a valid 1024x768 resolution available, which could be used
> by Anaconda for the graphical installation.

Assuming you now have the OS installed via text mode install, and have
updated to the latest packages from Fedora development, what does the
output of the following produce:

xrandr


Reviewing the BIOS reported video modes from the X server log, there is
no 1400x1050 mode reported, however there are a number of modes that look
bogus (0x0), etc.  Are you positive that in FC4 this worked, and that you
were not using i810resolution or similar utilities to override the BIOS
mode tables?

Comment 14 Mike A. Harris 2006-03-07 03:23:42 EST
Also, please post the X server log and config file from FC4 that you had that
worked and did not have this problem.  That will help narrow things down quite
a bit.

TIA
Comment 15 Richard Körber 2006-03-07 09:25:12 EST
The text mode installer is also broken (layout is messed up), so I was using
VNC. I have updated to the latest BIOS and the current developer xorg-x11 rpms.
(I couldn't update the entire system due to traffic limitations, sorry.)

All resolutions above 1024x768 are still unavailable after the update. xrandr
produces:

 SZ:    Pixels          Physical       Refresh
*0   1024 x 768    ( 302mm x 232mm )  *75
 1    800 x 600    ( 302mm x 232mm )   75
 2    640 x 480    ( 302mm x 232mm )   75
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none

I have only *tried to install* FC4 instead of FC5test3. As mentioned above, with
FC5test3 only a part of the installer screen was visible, so I was trying to
find out if the issue already occured on FC4. The FC4 installer was working
fine, showing the entire screen, but also not in full 1400x1050 resolution.

Actually I don't know if FC4 would also run a 1400x1050 resolution. The previous
owner of the notebook had a recent SuSE installed, and he told me that the full
resolution was supported on that system. I have never seen it myself, nor do I
have any SuSE log files I could provide.
Comment 16 Richard Körber 2006-03-07 10:41:56 EST
Tried FC4 right now. It supports only up to 1280x1024, also not the full resolution.

xrandr of FC4:

 SZ:    Pixels          Physical       Refresh
*0   1280 x 1024   ( 301mm x 230mm )  *0
 1   1024 x 768    ( 301mm x 230mm )   0
 2    800 x 600    ( 301mm x 230mm )   0
 3    640 x 480    ( 301mm x 230mm )   0
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none
Comment 17 Richard Körber 2006-03-07 10:47:38 EST
Created attachment 125758 [details]
Xorg.0.log of FC4
Comment 18 Richard Körber 2006-03-07 13:12:21 EST
Thinking twice about it... FC4 was able to use a 1280x1024 resolution. FC5test3
also detected a 1280x1024 resolution, but was unable to use it ("width too large
for virtual size") and fell back to 1024x768.

Could it be that FC5's Anaconda tried to display a 1280x1024 bitmap on a
1024x768 resolution, thus showing only the upper left 1024x768 pixels? This
could at least explain what I saw on the screen when I tried to install FC5test3.
Comment 19 Mike A. Harris 2006-03-08 01:27:10 EST
(In reply to comment #15)
> The text mode installer is also broken (layout is messed up), so I was using
> VNC. I have updated to the latest BIOS and the current developer xorg-x11 rpms.

The i810 driver isn't responsible for text mode installation though.  ;o)


> (I couldn't update the entire system due to traffic limitations, sorry.)
> 
> All resolutions above 1024x768 are still unavailable after the update. xrandr
> produces:
> 
>  SZ:    Pixels          Physical       Refresh
> *0   1024 x 768    ( 302mm x 232mm )  *75
>  1    800 x 600    ( 302mm x 232mm )   75
>  2    640 x 480    ( 302mm x 232mm )   75

Right, because your video BIOS does not support higher modes according to the
X server log file.

> I have only *tried to install* FC4 instead of FC5test3. As mentioned above, with
> FC5test3 only a part of the installer screen was visible, so I was trying to
> find out if the issue already occured on FC4. The FC4 installer was working
> fine, showing the entire screen, but also not in full 1400x1050 resolution.

I'm not entirely certain, but I believe anaconda runs in 800x600 or 1024x768
on all hardware, but I could be wrong.  You might want to confer with our
installer team about that.

> Actually I don't know if FC4 would also run a 1400x1050 resolution. The previous
> owner of the notebook had a recent SuSE installed, and he told me that the full
> resolution was supported on that system. I have never seen it myself, nor do I
> have any SuSE log files I could provide.

As mentioned previously, there are 3rd party utilities which can reprogram
the video BIOS modelists with alternative modes.  The primary utilities are
i810resolution and i915resolution - you can google for them and try them out
if you wish, however we do not ship them with Fedora Core.  SuSE may ship
them in their OS, and may perhaps even default to using them automatically
perhaps.  That's just a hypothesis however, I have no idea as I haven't
examined SuSE's X configuration setup.

There is a reason why we do not ship these utilities with the OS however,
which is because they are not foolproof, and are known to fail in many
circumstances resulting in unreliable operation.

If your video BIOS does not support a given video mode, then the X driver
can _not_ use it, because the driver _only_ uses the BIOS to do mode
programming.  There is a lot of laptops and other hardware out there in
which the supplied video BIOS does not support the native video mode of
the included panel.  That is a rather senseless hardware design, but
many manufacturers have done this shortsightedly anyways, thereby leaving
their Linux users with a very undesireable situation.

Google for the i810resolution/i915resolution utilities, and test them out,
manually configure X to use the modes you configure into the BIOS, and
see if it works.

Additionally, try using Option "noddc" in the device configuration, as
some displays report back bogus DDC data on Intel hardware (most notably
the Dell 2001FP).

Hope this helps.

Comment 20 Richard Körber 2006-03-08 07:45:18 EST
Thank you for your help. I will give i810resolution a try after I have installed
FC5-final on my notebook. But I would have to install FC5 first, which I cannot
because both the graphical installer and the text mode installer is broken. ;-)

The FC4 graphical installer was working fine on this notebook, so it seems to be
a regression in Anaconda. If you agree, maybe we should reassign this bug back
to the Anaconda team.
Comment 21 Richard Körber 2006-03-21 09:02:51 EST
This bug has been fixed on FC5 final for the Dell Inspiron 510m. Thanks!

Note You need to log in before you can comment on or make changes to this bug.