Bug 181762 - mono segfaults on PPC
Summary: mono segfaults on PPC
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-16 11:54 UTC by Hans de Goede
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 17:52:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2006-02-16 11:54:58 UTC
When trying to rebuild libgnomdedb for FE5 (note I'm the libgnomedb maintainer)
the build on the ppc buildserver fails with a segfault burried within mono,
strange enough libgda, who's sharp support code is very simular did build. This
is 100% reproducable (3 out of 3 tries).

Howto reproduce:
On a up2date rawhide ppc box do:
FE-cvs: cvs co libgnomedb
cd libgnomedb/devel
make srpm
maybe? rpmbuild -bb <srpm>
Probably for sure: build the srpm in mock

For logs see:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/4411-libgnomedb-1.9.100-5.fc5/

And then ppc/build.log

Comment 1 Alexander Larsson 2006-02-17 14:32:00 UTC
This seems to have built correctly:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/4411-libgnomedb-1.9.100-5.fc5/ppc/build.log

Or am i missing something?

Anyway, its unlikely that we'll be able to fix this. I'd recommend reporting it
to the upstream mono developers.

Comment 2 Hans de Goede 2006-02-17 17:52:59 UTC
Like I said 100% reproducable it failed 3/3 times, after a new rawhide release I
decided to try it again and the 4th time it worked, I've seen similar things
before so I'm not sure if the new rawhide did the trick.
Anyways I'll close this as works for me.



Note You need to log in before you can comment on or make changes to this bug.