Bug 181763 - Could not split insn Internal Compiler error
Could not split insn Internal Compiler error
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
http://www.paraview.org/files/v2.4/pa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-16 07:06 EST by John Watts
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 11:15:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Watts 2006-02-16 07:06:23 EST
Description of problem:
[dvdemo@dcv01 PARAVIEW64]$ make
-- Found existing Tcl, not rebuilding
-- Found existing Tk, not rebuilding
Building CXX object
VTK/Imaging/CMakeFiles/vtkImaging.dir/vtkImageEuclideanDistance.o
/DVDEMO/paraview-2.4.2/VTK/Imaging/vtkImageEuclideanDistance.cxx: In function
   `void vtkImageEuclideanDistanceInitialize(vtkImageEuclideanDistance*,
   vtkImageData*, T*, vtkImageData*, int*, double*) [with T = VTK_TT]':
/DVDEMO/paraview-2.4.2/VTK/Imaging/vtkImageEuclideanDistance.cxx:168: could not
   split insn
(insn:TI 496 325 499 (set (reg:DF 25 rxmm4 [141])
        (if_then_else:DF (ne (mem:DF (reg/v/f:DI 5 rdi [70]) [8 S8 A64])
                (reg:DF 25 rxmm4 [141]))
            (reg/v:DF 23 rxmm2 [97])
            (const_double:DF 0 [0x0] 0 [0x0] 0 [0x0]))) 660
{*sse_movdfcc_const0_3} (insn_list 614 (nil))
    (expr_list:REG_EQUIV (mem:DF (reg/v/f:DI 4 rsi [91]) [8 S8 A64])
        (nil)))
/DVDEMO/paraview-2.4.2/VTK/Imaging/vtkImageEuclideanDistance.cxx:168: Internal
   compiler error in final_scan_insn, at final.c:2624
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [VTK/Imaging/CMakeFiles/vtkImaging.dir/vtkImageEuclideanDistance.o]
Error 1
make[1]: *** [VTK/Imaging/CMakeFiles/vtkImaging.dir/all] Error 2
make: *** [all] Error 2


Version-Release number of selected component (if applicable):
[dvdemo@dcv01 PARAVIEW64]$ uname -a
Linux dcv01 2.4.21-20.ELsmp #1 SMP Wed Aug 18 20:34:58 EDT 2004 x86_64 x86_64
x86_64 GNU/Linux
[dvdemo@dcv01 PARAVIEW64]$ rpm -qa | grep gcc
compat-gcc-7.3-2.96.128
gcc-g77-3.2.3-42
gcc-objc-ssa-3.5ssa-0.20030801.48
libgcc-3.2.3-42
gcc-objc-3.2.3-42
libgcc-3.2.3-42
gcc-3.2.3-42
gcc-java-3.2.3-42
gcc-g77-ssa-3.5ssa-0.20030801.48
compat-gcc-c++-7.3-2.96.128
gcc-gnat-3.2.3-42
gcc-c++-ssa-3.5ssa-0.20030801.48
libgcc-ssa-3.5ssa-0.20030801.48
gcc-ssa-3.5ssa-0.20030801.48
gcc-c++-3.2.3-42
gcc-java-ssa-3.5ssa-0.20030801.48

How reproducible:
every time

Steps to Reproduce:
tar xvzf paraview-2.4.2.tar.gz
mkdir paraview-build
ccmake ../paraview-2.4.2
make && make install 


  
Actual results:
See above

Expected results:
Clean make and install


Additional info:
Comment 1 Alexandre Oliva 2006-02-24 02:23:06 EST
I'm missing the preprocessed testcase to debug this.  I realize I can download
the source package you mentioned (did) and try to build it myself, but then I'd
have to obtain ccmake and whatever else it might depend on :-)  Any chance you
could submit the preprocessed testcase instead?  Thanks,
Comment 2 Alexandre Oliva 2006-02-24 11:44:36 EST
I've just realized the oldish version of the compiler that you are using still
does not contain the code that helps distill preprocessed testcases and command
line arguments.  If updating to a newer compiler is an option, I suggest you try
that, since it might as well fix the problem to begin with.  If not, the idea is
to try to find out the exact command line used to compile this particular file,
then run that same command adding -save-temps to it, such that the compiler will
leave behind a .ii file with the same extension.  Then, compress the .ii file if
appropriate, attach it to this bug report and mention the command line in a comment.

In the mean time, I'll see if I get anywhere trying to obtain a working ccmake.
 It does not seem to be part of Red Hat Enterprise Linux, so it is not in the
toolset I have available on the hosts I'm supposed to use to debug problems in
the compiler.
Comment 3 Alexandre Oliva 2006-02-24 23:43:58 EST
I've managed to figure out that ccmake was part of cmake, downloaded version
2.2.3 for GNU/Linux/x86 from the web site, and used that to configure the tree
with default options.  I found it odd that I had to run `c'onfigure twice before
it would let me `g'enerate files, but the real show-stopper was that, when I ran
make, I got:

$ make
gmake: *** No targets specified and no makefile found.  Stop.
make[2]: *** [maketcltk] Error 1
make[1]: *** [Utilities/TclTk/CMakeFiles/maketcltk.dir/all] Error 2
make: *** [all] Error 2

I guess I'm going to need the preprocessed testcase to make any further progress
on this.
Comment 4 Jakub Jelinek 2006-05-26 11:15:59 EDT
Please reopen when you have preprocessed source.

Note You need to log in before you can comment on or make changes to this bug.