Bug 1817663 - Tracking BlueStore changes for RHCS 5
Summary: Tracking BlueStore changes for RHCS 5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 5.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 5.0
Assignee: Neha Ojha
QA Contact: skanta
URL:
Whiteboard:
Depends On:
Blocks: 1873221
TreeView+ depends on / blocked
 
Reported: 2020-03-26 18:11 UTC by Vikhyat Umrao
Modified: 2021-08-30 08:24 UTC (History)
12 users (show)

Fixed In Version: ceph-15.2.4-16.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1873221 (view as bug list)
Environment:
Last Closed: 2021-08-30 08:24:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 45265 0 None None None 2020-04-24 23:26:40 UTC
Github ceph ceph pull 33401 0 None closed doc/release/octopus: note about upgrade times 2021-01-31 17:00:22 UTC
Red Hat Issue Tracker RHCEPH-782 0 None None None 2021-08-19 16:40:55 UTC
Red Hat Product Errata RHBA-2021:3294 0 None None None 2021-08-30 08:24:52 UTC

Description Vikhyat Umrao 2020-03-26 18:11:59 UTC
Description of problem:
[RHCS 5] Tracking omap format change
https://github.com/ceph/ceph/pull/33401/files

Comment 1 Josh Durgin 2020-04-15 21:49:27 UTC
For 5.0 we'll turn off the format change by default, and document how to perform it with ceph-ansible.

Comment 11 skanta 2021-03-03 23:20:46 UTC
Moving the code change and tracking bug to verified state based on the automation regression run.

[ceph: root@magna045 /]# ceph -s
  cluster:
    id:     4185a64c-71b0-11eb-bae4-002590fbc342
    health: HEALTH_OK
 
  services:
    mon: 5 daemons, quorum magna045,magna049,magna046,magna048,magna047 (age 13d)
    mgr: magna045.pwohab(active, since 13d), standbys: magna046.ajvpup
    osd: 35 osds: 35 up (since 7h), 35 in (since 13d)
 
  data:
    pools:   1 pools, 1 pgs
    objects: 40 objects, 0 B
    usage:   596 MiB used, 100 TiB / 100 TiB avail
    pgs:     1 active+clean
 
[ceph: root@magna045 /]# ceph version
ceph version 16.1.0-100.el8cp (fd37c928e824870f3b214b12828a3d8f9d1ebbc1) pacific (rc)
[ceph: root@magna045 /]#

Comment 16 errata-xmlrpc 2021-08-30 08:24:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat Ceph Storage 5.0 bug fix and enhancement), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3294


Note You need to log in before you can comment on or make changes to this bug.