This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 181774 - nautilus crashes with BadAlloc error in .xsession-errors
nautilus crashes with BadAlloc error in .xsession-errors
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: metacity (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-16 09:36 EST by K Donate
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 15:23:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
.xsession.errors file (6.59 KB, text/plain)
2006-02-16 09:49 EST, K Donate
no flags Details
.xsession-errors file (924 bytes, text/plain)
2006-02-16 09:50 EST, K Donate
no flags Details

  None (edit)
Description K Donate 2006-02-16 09:36:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
This problem is dificult to duplicate.  Users report nautilus crashing often during similar application use.  However, they are also more often than not able to perform the required steps inthe application without the crash.

Regardless, at first just the window title bars disappear or get corrupted with color blocks.  Then things progress to window menus popping up in non-relative positions to the window they belong to.  For example, I have a terminal window in the lower left corner of the screen.  I click on the File menu.  The file menu will actually pop up in the upper right of the desktop.

Often, as things degrade, text in the window titles and menus are no longer readible or visible.  Attachment .xsession-errors.1 has some BadAlloc error messages in it that may help.

Yesterday, things progressed to a point such that the user had absolutely no control over items on the desktop.  Eventually all the windows disappeared including his trash and home icons.  The .xsession-errors.2 file is from yesterday, saved after this event occured.

I wish I had more for you, but I'm not were to look.  The users are using eXceed and VNC to connect to the IBM xseries 336 boxes running RH WS3.  The problem occurs more frequently when eXceed is being used.  It has only happened once in the past week using VNC.  I've asked the users to notify as early as possible when the crash occurs so I can grab a screen shot.

Thank you.



Version-Release number of selected component (if applicable):
nautilus-2.2.4-6.E

How reproducible:
Sometimes

Steps to Reproduce:
1. 
2.
3.
  

Actual Results:  Window titles are "messed up", windows stop responding, window menu do align with their respective windows.  Evenutally, all windows disappear are are unrecognizable.

Expected Results:  none of that,

Additional info:

** (nautilus:12778): WARNING **: Throbber activation exception 'Child process did not give an error message, unknown failure occurred'
The program 'nautilus' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 293876 error_code 11 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Comment 1 K Donate 2006-02-16 09:49:31 EST
Created attachment 124751 [details]
.xsession.errors file
Comment 2 K Donate 2006-02-16 09:50:56 EST
Created attachment 124752 [details]
.xsession-errors file
Comment 3 Alexander Larsson 2006-02-17 09:27:44 EST
Does the mispositioning and discoloring only happen for nautilus windows and
menus, or for other applications too?
Comment 4 K Donate 2006-02-17 09:36:56 EST
All the windows, nautilus and other apps.
Comment 5 Alexander Larsson 2006-02-17 09:57:35 EST
Then I don't think this is really a nautilus bug. Nautilus is just suffering
more than other apps from it. I'm not really sure where the real bug is though.
Maybe in eXceed, vnc, or the window manager.
Comment 6 K Donate 2006-02-17 10:02:41 EST
Good point.  I hadn't really thought about it like that.  But, I needed to start
somewhere to get help with this problem.

eXceed and VNC never crash themselves.  They both stay operational, although you
can't do much of anything since the Linux windows themselves are either gone or
not responding.  I tend to think the window manager may be the next area to
investigate.

What additional information can I try to get the determine the source of the
problem?
Comment 7 Alexander Larsson 2006-02-20 04:47:46 EST
I'm sorry, i can't help much wrt eXceed, VNC and window managers.
Comment 8 K Donate 2006-02-20 08:11:19 EST
The users are using Gnome, which I believe uses metacity as the window manager.
 How do I go about moving this bug over to those products?
Comment 9 Alexander Larsson 2006-02-20 12:14:04 EST
Just change the component.
Comment 10 Søren Sandmann Pedersen 2006-09-06 15:23:50 EDT
Without either access to the system or more information, it is impossible to say
what this could be.
Comment 11 Søren Sandmann Pedersen 2006-09-06 15:25:48 EDT
For official Red Hat Enterprise Linux support, please log into the Red Hat
support website at http://www.redhat.com/support and file a support ticket,
or alternatively contact Red Hat Global Support Services at 1-888-RED-HAT1
to speak directly with a support associate and escalate an issue.
Comment 12 K Donate 2006-09-06 21:36:31 EDT
Not once did anyone ask me to supply additional data.  Perhaps that request
should have been made before closing due to "insufficient data".

Thanks for your help.  :-(
Comment 13 Søren Sandmann Pedersen 2006-09-07 12:48:11 EDT
Well, I can change the resolution to "CANTFIX" if you'd like, but I don't see
any way to fix this, as there isn't even a way to know which component is
responsible for the bug.

As I also said, for support for Red Hat Enterprise Linux, you need to use the
Red Hat support website at http://www.redhat.com/support and file a support ticket.

Note You need to log in before you can comment on or make changes to this bug.