Bug 181785 - xorg-x11-apps - luit has wrong locale location - modular-x
xorg-x11-apps - luit has wrong locale location - modular-x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-apps (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-16 11:03 EST by Jiri Slaby
Modified: 2013-01-09 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 07:16:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This patch may be considered as a way to solve this problem (659 bytes, patch)
2006-02-16 11:03 EST, Jiri Slaby
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 173702 None None None Never

  None (edit)
Description Jiri Slaby 2006-02-16 11:03:25 EST
+++ This bug was initially created as a clone of Bug #173702 +++
-----------------------------------
In xorg-x11-apps-1.0.1-1.2 there is
# strings /usr/bin/luit |grep usr
/usr/lib/X11/locale/locale.alias
# rpm -ql libX11|grep alias
/usr/share/X11/locale/locale.alias
# strace -e open luit
...
open("/usr/lib/X11/locale/locale.alias", O_RDONLY) = -1 ENOENT (No such file or
directory)
Warning: couldn't find charset data for locale cs_CZ.UTF-8; using ISO 8859-1.
# rpm -q libX11 xorg-x11-apps
libX11-1.0.0-2.2
xorg-x11-apps-1.0.1-1.2

due to:
%{_datadir}/X11/locale/locale.alias 
libX11-0.99.3-datadir-locale-dir-fix.patch
from libX11 src rpm and
LOCALEALIASFILE=${libdir}/X11/locale/locale.alias
from luit configure script

I attach patch that would help, there is also need to change specfile to execute
autoconf.
Comment 1 Jiri Slaby 2006-02-16 11:03:25 EST
Created attachment 124760 [details]
This patch may be considered as a way to solve this problem
Comment 2 Mike A. Harris 2006-02-24 07:07:44 EST
Thanks for the report and patch.  Applied to 1.0.1-2 in rawhide.

[root@fc4i386 RPMS]# rpm -Uvh xorg-x11-apps-1.0.1-2.i386.rpm
Preparing...                ########################################### [100%]
   1:xorg-x11-apps          ########################################### [100%]
You have new mail in /var/spool/mail/root
[root@fc4i386 RPMS]# strings /usr/bin/luit |grep usr
/usr/share/X11/locale/locale.alias

Note You need to log in before you can comment on or make changes to this bug.