Bug 181786 - Unnecessary Build Requires [PATCH]
Unnecessary Build Requires [PATCH]
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-16 11:10 EST by Brian Pepple
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-01 11:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to modify spec file (1.40 KB, patch)
2006-02-16 11:10 EST, Brian Pepple
no flags Details | Diff

  None (edit)
Description Brian Pepple 2006-02-16 11:10:07 EST
Description of problem:
There's a couple of BR for evince that are unnecessary since they are pulled in
by other packages

Version-Release number of selected component (if applicable):
0.5.0-3.2

How reproducible: Always

Duplicate BuildRequires: scrollkeeper (by nautilus), gtk2-devel (by
libgnomeprintui22-devel), libglade2-devel (by libgnomeui-devel),
gnome-vfs2-devel (by libgnomeui-devel)
Comment 1 Brian Pepple 2006-02-16 11:10:07 EST
Created attachment 124761 [details]
Patch to modify spec file
Comment 2 Matthias Clasen 2007-04-01 11:02:48 EDT
I've dropped the no longer needed libgnomeprintui22 BR, but I disagree about the
rest. If a package is explicitly checked for in configure, it is good form to
list it as a BR in the spec, instead of some other package that happens to pull
it in.

Note You need to log in before you can comment on or make changes to this bug.