Bug 181792 - volume slider in firstboot widget not correct for RTL locales
Summary: volume slider in firstboot widget not correct for RTL locales
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-16 16:38 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 10:24:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testing script (7.34 KB, application/octet-stream)
2006-02-21 07:48 UTC, Martin Stransky
no flags Details

Description Jeremy Katz 2006-02-16 16:38:29 UTC
Installed in Persian and the volume slider on the soundcard page in firstboot
acts... odd.  Moving the slider causes the colored region to move in the other
direction.

Comment 1 Martin Stransky 2006-02-16 22:00:49 UTC
Could you be more specific how to reproduce this bug?

Comment 2 Jeremy Katz 2006-02-16 22:20:26 UTC
Just run system-config-soundcard in an RTL locale such as fa_IR.UTF-8 with the
default theme, watch the volume slider not work in a consistent fashion.

Comment 3 Martin Stransky 2006-02-17 13:21:34 UTC
hmm, it works fine for me, I'll check it on some other boxes...

Comment 4 Martin Stransky 2006-02-20 14:55:20 UTC
I'm unable to reproduce it on any box...please reopen if you have any idea how I
can reproduce this bug...

Comment 5 Jeremy Katz 2006-02-20 20:12:06 UTC
Please.  Fresh install of FC5 test3, all stock settings.

# LANG=fa_IR.UTF-8 system-config-soundcard

See the screenshot at http://people.redhat.com/~katzj/persian-soundcard.png. 
That volume slider is not at all doing the right thing.


Comment 6 Martin Stransky 2006-02-21 07:47:10 UTC
This works for my perfectly on fresh installed FC5 test3. What is the problem?
The slider doesn't work or does it work fine (adjusts the volume) with strange
graphics effects? Coud you check some other applications with sliders? (I'll
attach one).

Comment 7 Martin Stransky 2006-02-21 07:48:18 UTC
Created attachment 124943 [details]
testing script


Note You need to log in before you can comment on or make changes to this bug.