Bug 18181 - RPM confused about which package is newer.
Summary: RPM confused about which package is newer.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-03 05:22 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 05:22:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-03 05:22:54 UTC
I have just completed an upgrade of a RedHat 6.2 + Helix Gnome system to
7.0.
I was somewhat surprised how many helix packages, some of which were
extremely
current, were wiped out by the upgrade.

When trying to reinstall some of them I had the following experience which
suggests that
something may be wrong with rpm-4.0-4:

# rpm -U dia-0.86-0_helix_1.i386.rpm
package dia-0.84-6 (which is newer than dia-0.86-0_helix_1) is already
installed

It would seem that rpm is wrong about which package is newer.

Thanks

   Gisli

PS: What's the deal with http://www.rpm.org and http://rpm.redhat.com?  The
info
presented on these pages is ca. 1 1/2 years out of date.

Comment 1 Bill Nottingham 2000-10-03 13:59:06 UTC
One package has a serial number, the other doesn't.

You can determine this by doing:

rpm -qp --qf "%{SERIAL}\n" <package>

Comment 2 Jamie Manley 2000-10-06 02:42:21 UTC
How does one work around this for locally compiled RPMs?  Am I stuck with the
versions Redhat installed?

[root@spiritwalk i386]# rpm -Uvh gdk-pixbuf-*
package gdk-pixbuf-0.8.0-5 (which is newer than gdk-pixbuf-0.9.0-1) is already
installed
package gdk-pixbuf-devel-0.8.0-5 (which is newer than gdk-pixbuf-devel-0.9.0-1)
is already installed


Note You need to log in before you can comment on or make changes to this bug.