Bug 181829 - SELinux relabeling - Kadischi
SELinux relabeling - Kadischi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-16 16:58 EST by Jasper O. Hartline
Modified: 2014-03-16 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 14:12:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kadischi - SELinux relabel - Init Scripts patch (320 bytes, patch)
2006-02-16 17:02 EST, Jasper O. Hartline
no flags Details | Diff

  None (edit)
Description Jasper O. Hartline 2006-02-16 16:58:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
During rc.sysinit we try and touch /.autorelabel.
Using Kadischi as a standalone system this is unneccessary since we are in readonly root mode. Here, I think we may be able to check the status of $READONLY
and depending on it decide if we should touch /.autorelabel.

This is a merely cosmetic issue in Kadischi, and depending on what the higher-up have in store for Kadischi, may not be neccessary or in the least bit plausible.

Feedback please, a patch is attached below against the initscripts in development.


Version-Release number of selected component (if applicable):
8.29-1

How reproducible:
Always

Steps to Reproduce:
1. Build a Fedora Core LiveDVD(or CD).
2. Bootstrap the LiveDVD media.
3. Undesirable error of not being able to touch ./autorelabel (Read Only Root)
  

Actual Results:  Unneccessary message from sys

Expected Results:  Clean bootstrap.

Additional info:

Patch against initscripts-8.29-1 attached below.
No additional information at this time.
Comment 1 Jasper O. Hartline 2006-02-16 17:02:57 EST
Created attachment 124792 [details]
Kadischi - SELinux relabel - Init Scripts patch
Comment 2 Jasper O. Hartline 2006-03-16 23:21:37 EST
Hi.
Anything come of this?
They are listed at the fedoraproject.org/wiki/Kadischi/Schedule as a todo.

I'll resend another patch against initscripts from FC5 final in a few days.
Like I said, it really is purely cosmetic, but cosmetic is important too I suppose.

Thank you for your time.
Comment 3 Jasper O. Hartline 2006-07-03 09:32:46 EDT
Being a cosmetic issue in LiveCD creation and bootstrap, is it possible we can
just send this output to /dev/null or is this neccessary right now for debugging
issues?

If the rootfs is SquashFS and readonly-root we know we'll get some nasty output.
Comment 4 Miloslav Trmač 2006-11-10 14:12:11 EST
This was fixed in FC6.

Note You need to log in before you can comment on or make changes to this bug.