Bug 18183 - RAID install fails if you have IDE + SCSI
RAID install fails if you have IDE + SCSI
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 01:56 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 12:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-03 01:56:19 EDT
Hello,

On RH 6.2 I had a working install with 3 drives.  hda and hdb are
identical, and were
my software raid 1 set for mirroring and I booted off of that.  My sda is
used for storing database
information.  The machine is a Dell Precision 410.  It has 2 400MHZ PII
cpus.  The
motherboard has a built-in adaptec controller that was controlling the IBM
scsi-2 drive.
Anyway, when trying a fresh install I figured ok, I'd just wipe everything
and 
set up raid as part of the install [instead of doing it later like I did on
rh 6.2].  When
trying this, the install said I could only use hda and sda, since those are
the first
2 drives.  Actually, hda and hdb are the first 2 drives on my machine.  

I did an upgrade and the RH7 seemed to work with my existing md0 raid1 set
just fine.
I think this is a logic bug in your installer somehow since most people
don't have
2 ide drives and a scsi drive and then choose to make an md0 set out of the
2 ide
drives and boot off of that.

So the workaround is either upgrade, or install the hard way [just install
on hda, then
later set up software raid and let it rebuild hdb as part of a recovery]. 
Still, for rh 7.1
you might wanna fix this problem, or document it.

John Ham

The scsi adapter and drive data is here:

(scsi0) <Adaptec AIC-7890/1 Ultra2 SCSI host adapter> found at PCI 2/10/0
(scsi0) Wide Channel, SCSI ID=7, 32/255 SCBs
(scsi0) Downloading sequencer code... 392 instructions downloaded
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.31/3.2.4
       <Adaptec AIC-7890/1 Ultra2 SCSI host adapter>
scsi : 1 host.
(scsi0:0:2:0) Synchronous at 40.0 Mbyte/sec, offset 31.
  Vendor: IBM       Model: DNES-318350W      Rev: SA30
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sda at scsi0, channel 0, id 2, lun 0

The ide adapter and drive data is here:

PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
hda: Maxtor 90432D3, ATA DISK drive
hdb: Maxtor 90432D3, ATA DISK drive
hdc: NEC CD-ROM DRIVE:28B, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: Maxtor 90432D3, 4121MB w/256kB Cache, CHS=525/255/63, UDMA
hdb: Maxtor 90432D3, 4121MB w/256kB Cache, CHS=525/255/63, UDMA
hdc: ATAPI 32X CD-ROM drive, 256kB Cache
Uniform CD-ROM driver Revision: 3.11
Comment 1 Michael Fulbright 2000-10-03 15:35:33 EDT
Brent please reproduce. 
Comment 2 Michael Fulbright 2001-09-17 14:48:37 EDT
Brent please try this out with roswell.
Comment 3 Brent Fox 2001-09-18 12:08:15 EDT
Ok, looking at this now.
Comment 4 Brent Fox 2001-09-18 15:25:16 EDT
This works fine for me with our latest tree.  All of the partitioning code has
been replaced with *new-and-improved* partitioning code, so it looks like this
problem has disappeared.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.