Bug 181839 - Dependency issue - Evolution or krb5-auth-dialog on NetworkManager on caching-nameserver
Dependency issue - Evolution or krb5-auth-dialog on NetworkManager on caching...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-16 22:50 EST by John Tapparo
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 10:55:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Tapparo 2006-02-16 22:50:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
First, I am not quite sure which component is at fault here.  I picked NetworkManager because it seems the common denominator and I don't think it has a library dependency so it could break the dependency chain.

I cannot remove the caching-nameserver from my system without also removing evolution and krb5-auth-dialog.  This seems like a bizarre dependency outcome.

krb5-auth-dialog and evolution require libnm-glib.so.0
libnm-glib.so.0 is provided by NetworkManager-glib
NetworkManager-glib require NetworkManager
NetworkManager requires caching-nameserver

Version-Release number of selected component (if applicable):
NetworkManager-glib-0.5.1-12.cvs20060213

How reproducible:
Always

Steps to Reproduce:
1. rpm -e caching-nameserver says that NetworkManager needs it
2. rpm -e NetworkManager says that NetworkManager-gnome and NetworkManager-glib need it.
3. rpm -e NetworkManager-glib says that evolution and krb5-auth-dialog need it.

Example:
# rpm -e caching-nameserver
error: Failed dependencies:
        caching-nameserver is needed by (installed) NetworkManager-0.5.1-12.cvs20060213.i386
# rpm -e caching-nameserver NetworkManager
error: Failed dependencies:
        libnm-util.so.0 is needed by (installed) NetworkManager-gnome-0.5.1-12.cvs20060213.i386
        NetworkManager = 0.5.1-12.cvs20060213 is needed by (installed) NetworkManager-glib-0.5.1-12.cvs20060213.i386
        NetworkManager = 0.5.1-12.cvs20060213 is needed by (installed) NetworkManager-gnome-0.5.1-12.cvs20060213.i386
# rpm -e caching-nameserver NetworkManager NetworkManager-glib NetworkManager-gnome
error: Failed dependencies:
        libnm_glib.so.0 is needed by (installed) evolution-2.5.90-2.1.i386
        libnm_glib.so.0 is needed by (installed) krb5-auth-dialog-0.6.cvs20060212-1.i386

  

Actual Results:  I stopped (and left caching-nameserver installed on my system) because I wanted to leave evolution installed.

Expected Results:  I should have been able to remove the caching-nameserver rpm without removing evolution.

Additional info:

I don't know if forcing the removal of caching-nameserver is an appropriate work around.  However I suspect that if I do that and yum updates NetworkManager, it will probably reinstall caching-nameserver (because it's a prereq) and clobber my named.conf and disrupt my DNS resolution.

Now to really overstep my bounds: is a possible solution to make NetworkManager work with or without the caching-nameserver piece and remove caching-nameserver as a dependency to NetworkManager?

The reason that I want to remove the caching-nameserver is that I run a DNS server in my SOHO network to provide resolution of internal addresses (and to cache others).  The machine that acts as the DNS server is also my desktop machine (hence evolution).

RPMs Installed:
krb5-auth-dialog-0.6.cvs20060212-1
evolution-2.5.90-2.1
NetworkManager-glib-0.5.1-12.cvs20060213
NetworkManager-gnome-0.5.1-12.cvs20060213
NetworkManager-0.5.1-12.cvs20060213
caching-nameserver-7.3-4.FC5
Comment 1 Rahul Sundaram 2006-02-20 06:25:56 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 John Tapparo 2006-03-30 00:00:05 EST
This may no longer be a huge issue since caching-nameserver has been replaced by
bind-config.  It also looks like bind-config no longer wants to clobber my
/etc/named.conf file (but I have not actually tried an update of bind-config
with a custom /etc/named.conf file on my system).

I did not close this yet because I don't know if NetworkManager knows that
caching-nameserver is gone caching-nameserver is still listed as a dependency
for NetworkManager-0.6.0-3 installed on my FC5 system.
Comment 3 Red Hat Bugzilla 2007-02-05 14:30:26 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 4 Matthew Miller 2007-04-06 14:52:26 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 John Tapparo 2007-11-02 09:13:26 EDT
This issue no longer seems to be a problem in F7.  I was able to remove the
caching-nameserver package while leaving NetworkManager and evolution in place
on one of my Fedora 7 machines (x86_64).

I am not sure if I'm supposed to close this bug somehow or not.  (And I wouldn't
know what close code to use).
Comment 6 Dan Williams 2007-11-02 10:55:30 EDT
ok, thanks.

Note You need to log in before you can comment on or make changes to this bug.