Bug 1818451 - attempting to access a gcc command line option that is not stored in global_options
Summary: attempting to access a gcc command line option that is not stored in global_o...
Keywords:
Status: CLOSED DUPLICATE of bug 1817659
Alias: None
Product: Fedora
Classification: Fedora
Component: annobin
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-28 08:45 UTC by Tomasz Kłoczko
Modified: 2020-03-28 14:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-28 14:00:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomasz Kłoczko 2020-03-28 08:45:07 UTC
$ rpm -q gcc annobin
gcc-10.0.1-0.10.fc33.x86_64
annobin-9.14-1.fc33.x86_64


Exampe output on building glib-networ which os now presend on build anything.

+ /usr/bin/ninja -v -j48 -C x86_64-redhat-linux-gnu
ninja: Entering directory `x86_64-redhat-linux-gnu'
[1/34] gcc -Iproxy/tests/c04dfc8@@libproxy@exe -Iproxy/tests -I../proxy/tests -I. -I../ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -std=c99 -DHAVE_CONFIG_H '-DG_LOG_DOMAIN="GLib-Net"' -DG_LOG_USE_STRUCTURED '-DLOCALE_DIR="/usr/share/locale"' -DG_DISABLE_DEPRECATED -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_56 -Werror=declaration-after-statement -Werror=implicit-function-declaration -O2 -g -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -flto=auto -flto-partition=none -pthread '-DSRCDIR="/home/tkloczko/rpmbuild/BUILD/glib-networking-2.64.1/proxy/tests"' '-DTOP_BUILDDIR="/home/tkloczko/rpmbuild/BUILD/glib-networking-2.64.1/x86_64-redhat-linux-gnu"' -MD -MQ 'proxy/tests/c04dfc8@@libproxy@exe/libproxy.c.o' -MF 'proxy/tests/c04dfc8@@libproxy@exe/libproxy.c.o.d' -o 'proxy/tests/c04dfc8@@libproxy@exe/libproxy.c.o' -c ../proxy/tests/libproxy.c
annobin: ../proxy/tests/libproxy.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../proxy/tests/libproxy.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../proxy/tests/libproxy.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../proxy/tests/libproxy.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../proxy/tests/libproxy.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../proxy/tests/libproxy.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../proxy/tests/libproxy.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../proxy/tests/libproxy.c: ICE: Please contact the annobin maintainer with details of this problem
[2/34] gcc -Itls/base/af60d8f@@tlsbase@sta -Itls/base -I../tls/base -I. -I../ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -std=c99 -DHAVE_CONFIG_H '-DG_LOG_DOMAIN="GLib-Net"' -DG_LOG_USE_STRUCTURED '-DLOCALE_DIR="/usr/share/locale"' -DG_DISABLE_DEPRECATED -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_56 -Werror=declaration-after-statement -Werror=implicit-function-declaration -O2 -g -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -flto=auto -flto-partition=none -fPIC -MD -MQ 'tls/base/af60d8f@@tlsbase@sta/gtlsinputstream.c.o' -MF 'tls/base/af60d8f@@tlsbase@sta/gtlsinputstream.c.o.d' -o 'tls/base/af60d8f@@tlsbase@sta/gtlsinputstream.c.o' -c ../tls/base/gtlsinputstream.c
annobin: ../tls/base/gtlsinputstream.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../tls/base/gtlsinputstream.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../tls/base/gtlsinputstream.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../tls/base/gtlsinputstream.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../tls/base/gtlsinputstream.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../tls/base/gtlsinputstream.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../tls/base/gtlsinputstream.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../tls/base/gtlsinputstream.c: ICE: Please contact the annobin maintainer with details of this problem
[3/34] gcc -Iproxy/gnome/bb3945d@@giognomeproxy@sha -Iproxy/gnome -I../proxy/gnome -I. -I../ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gsettings-desktop-schemas -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -std=c99 -DHAVE_CONFIG_H '-DG_LOG_DOMAIN="GLib-Net"' -DG_LOG_USE_STRUCTURED '-DLOCALE_DIR="/usr/share/locale"' -DG_DISABLE_DEPRECATED -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_56 -Werror=declaration-after-statement -Werror=implicit-function-declaration -O2 -g -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -flto=auto -flto-partition=none -fPIC -pthread -MD -MQ 'proxy/gnome/bb3945d@@giognomeproxy@sha/gproxyresolvergnome.c.o' -MF 'proxy/gnome/bb3945d@@giognomeproxy@sha/gproxyresolvergnome.c.o.d' -o 'proxy/gnome/bb3945d@@giognomeproxy@sha/gproxyresolvergnome.c.o' -c ../proxy/gnome/gproxyresolvergnome.c
annobin: ../proxy/gnome/gproxyresolvergnome.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../proxy/gnome/gproxyresolvergnome.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../proxy/gnome/gproxyresolvergnome.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../proxy/gnome/gproxyresolvergnome.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../proxy/gnome/gproxyresolvergnome.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../proxy/gnome/gproxyresolvergnome.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ../proxy/gnome/gproxyresolvergnome.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ../proxy/gnome/gproxyresolvergnome.c: ICE: Please contact the annobin maintainer with details of this problem

Comment 1 Marek Polacek 2020-03-28 14:00:33 UTC

*** This bug has been marked as a duplicate of bug 1817659 ***


Note You need to log in before you can comment on or make changes to this bug.