Bug 1818508 - [abrt] blivet-gui-runtime: __getattr__(): client.py:87:__getattr__:AttributeError: swap has no attribute relabels
Summary: [abrt] blivet-gui-runtime: __getattr__(): client.py:87:__getattr__:AttributeE...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8cf54f4a10877ee8489cecbc271...
: 1813588 1818498 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-28 20:09 UTC by Jan Vlug
Modified: 2020-04-03 19:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-03 19:16:07 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (971 bytes, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details
File: blivet-gui-utils.log (5.68 KB, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details
File: blivet.log (77.41 KB, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details
File: cpuinfo (2.38 KB, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details
File: environ (1.73 KB, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details
File: mountinfo (3.56 KB, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details
File: namespaces (129 bytes, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details
File: open_fds (1.46 KB, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details
File: program.log (32.72 KB, text/plain)
2020-03-28 20:09 UTC, Jan Vlug
no flags Details

Description Jan Vlug 2020-03-28 20:09:28 UTC
Description of problem:
Clicking somwhere in blivet-gui

Version-Release number of selected component:
blivet-gui-runtime-2.1.12-1.fc31

Additional info:
reporter:       libreport-2.12.0
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/gnome-launched-blivet-gui.desktop-330796.scope
cmdline:        /usr/bin/python3 /usr/bin/blivet-gui
crash_function: __getattr__
exception_type: AttributeError
executable:     /usr/bin/blivet-gui
interpreter:    python3-3.7.6-2.fc31.x86_64
kernel:         5.5.7-200.fc31.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
client.py:87:__getattr__:AttributeError: swap has no attribute relabels

Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/blivetgui/list_partitions.py", line 312, in on_partition_selection_changed
    self.activate_action_buttons(model[treeiter])
  File "/usr/lib/python3.7/site-packages/blivetgui/list_partitions.py", line 273, in activate_action_buttons
    if self._allow_relabel_device(device):
  File "/usr/lib/python3.7/site-packages/blivetgui/list_partitions.py", line 228, in _allow_relabel_device
    return device.format.labeling() and device.format.relabels()
  File "/usr/lib/python3.7/site-packages/blivetgui/communication/client.py", line 87, in __getattr__
    raise remote_attr
AttributeError: swap has no attribute relabels

Local variables in innermost frame:
self: <blivetgui.communication.client.ClientProxyObject object at 0x7f51041306d0>
attr_name: 'relabels'
remote_attr: AttributeError('swap has no attribute relabels')

Comment 1 Jan Vlug 2020-03-28 20:09:31 UTC
Created attachment 1674347 [details]
File: backtrace

Comment 2 Jan Vlug 2020-03-28 20:09:33 UTC
Created attachment 1674348 [details]
File: blivet-gui-utils.log

Comment 3 Jan Vlug 2020-03-28 20:09:35 UTC
Created attachment 1674349 [details]
File: blivet.log

Comment 4 Jan Vlug 2020-03-28 20:09:36 UTC
Created attachment 1674350 [details]
File: cpuinfo

Comment 5 Jan Vlug 2020-03-28 20:09:38 UTC
Created attachment 1674351 [details]
File: environ

Comment 6 Jan Vlug 2020-03-28 20:09:39 UTC
Created attachment 1674352 [details]
File: mountinfo

Comment 7 Jan Vlug 2020-03-28 20:09:41 UTC
Created attachment 1674353 [details]
File: namespaces

Comment 8 Jan Vlug 2020-03-28 20:09:42 UTC
Created attachment 1674354 [details]
File: open_fds

Comment 9 Jan Vlug 2020-03-28 20:09:44 UTC
Created attachment 1674355 [details]
File: program.log

Comment 10 Vojtech Trefny 2020-03-30 10:53:20 UTC
*** Bug 1818498 has been marked as a duplicate of this bug. ***

Comment 11 Vojtech Trefny 2020-03-30 10:53:24 UTC
*** Bug 1813588 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2020-03-30 11:27:40 UTC
FEDORA-2020-6474854cb4 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6474854cb4

Comment 13 Fedora Update System 2020-03-31 02:25:33 UTC
FEDORA-2020-6474854cb4 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-6474854cb4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6474854cb4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Jan Vlug 2020-04-01 21:06:41 UTC
Similar problem has been detected:

Clicking on a swap partition on a logical volume group.

reporter:       libreport-2.12.0
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/gnome-launched-blivet-gui.desktop-331544.scope
cmdline:        /usr/bin/python3 /usr/bin/blivet-gui
crash_function: __getattr__
exception_type: AttributeError
executable:     /usr/bin/blivet-gui
interpreter:    python3-3.7.6-2.fc31.x86_64
kernel:         5.5.7-200.fc31.x86_64
package:        blivet-gui-runtime-2.1.12-1.fc31
reason:         client.py:87:__getattr__:AttributeError: swap has no attribute relabels
runlevel:       N 5
type:           Python3
uid:            1000

Comment 15 Fedora Update System 2020-04-03 19:16:07 UTC
FEDORA-2020-6474854cb4 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.