Bug 181858 - yum fails to install conditional packages during groupinstall
yum fails to install conditional packages during groupinstall
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: 171491 FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-17 02:39 EST by Tim Mayberry
Modified: 2014-01-21 17:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 13:11:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum plugin to support conditional package request type (1.74 KB, text/x-python)
2006-02-20 20:41 EST, Tim Mayberry
no flags Details
patch to yum spec file (848 bytes, patch)
2006-02-20 20:58 EST, Tim Mayberry
no flags Details | Diff
patch to yum spec file (848 bytes, patch)
2006-02-20 21:00 EST, Tim Mayberry
no flags Details | Diff
Updated plugin (1.74 KB, text/plain)
2006-02-21 10:28 EST, Paul Nasrat
no flags Details
log of conditional group support in yum (13.95 KB, text/x-log)
2006-02-21 20:47 EST, Tim Mayberry
no flags Details

  None (edit)
Description Tim Mayberry 2006-02-17 02:39:17 EST
Description of problem:

According to this email on the yum-devel list

https://lists.dulug.duke.edu/pipermail/yum-devel/2006-February/001896.html

The format of the comps.xml file was changed recently to support conditional
packages that could be installed when certain requirements were met. I think the
only use for this at the moment is to install language support packages for
applications like open office, aspell and for KDE.

From what I can tell from reading this email:

https://lists.dulug.duke.edu/pipermail/yum-devel/2006-February/001923.html

A yum plugin is needed for this to work properly, and as this plugin has not
made it into the yum that is packaged for Rawhide installation of language
support doesn't work properly.

Version-Release number of selected component (if applicable):

yum-2.5.1-5

How reproducible:

yum groupinstall 'Chinese Support'

Actual results:

Only installs mandatory and default packages.

Expected results:

Installs mandatory, default and conditional packages(if requirements are met)
Comment 1 Tim Mayberry 2006-02-20 20:41:12 EST
Created attachment 124927 [details]
yum plugin to support conditional package request type
Comment 2 Tim Mayberry 2006-02-20 20:58:40 EST
Created attachment 124928 [details]
patch to yum spec file

patch to yum spec file that I used to test the condgroup plugin.
Comment 3 Tim Mayberry 2006-02-20 21:00:17 EST
Created attachment 124929 [details]
patch to yum spec file

patch to yum spec file that I used to test the condgroup plugin.
Comment 4 Tim Mayberry 2006-02-20 21:09:52 EST
I used the plugin available at the second URL, with the version of yum in 
rawhide and FC5 test3 and encountered some problems. One of which was that if a
group contained only conditional package requests such as the group 'Danish
Support' then no packages would get installed.

If a group contained both mandatory and conditional packages then the
conditional packages would be installed if the requirements were met, but
although yum groupinstall 'Hindi Support' worked and installed all the
conditional packages correctly, yum groupinstall 'Chinese Support' would not and
gave me an error.

I've attached the condgroup plugin and a patch to the yum spec file that I used.
Comment 5 Tim Mayberry 2006-02-20 22:51:21 EST
Comment on attachment 124928 [details]
patch to yum spec file

removing dupe of patch
Comment 6 Warren Togami 2006-02-20 23:53:21 EST
adding the person who worked on making the "conditional" thing

Comment 7 Paul Nasrat 2006-02-21 10:28:35 EST
Created attachment 124959 [details]
Updated plugin

I've an updated version of the plugin which I'd be grateful if you would test
before commiting.  This will resolve deps for conditional packages in the
group.
Comment 8 Tim Mayberry 2006-02-21 20:45:21 EST
I installed Test3 this morning without any extra language support and did a
little testing with the updated plugin.

I tried yum groupinstall for 'Chinese Support', 'Danish Support' and 'Hindi
Support'. I've attached a log that showing that using the existing yum
installation of conditional packages fails in each case. I then installed an
updated yum which was built using the updated plugin and the yum spec file patch
and performed the same tests. You can see from the log that although 'Chinese
Support' and 'Hindi Support' both work correctly and conditional packages are
scheduled for installation 'Danish Support' fails, I'm guessing this has
something to do with the fact that the 'Danish Support' package group only
contains conditional packages.
Comment 9 Tim Mayberry 2006-02-21 20:47:19 EST
Created attachment 124997 [details]
log of conditional group support in yum
Comment 10 Warren Togami 2006-02-23 00:51:38 EST
Nasrat, when this plugin is working fully, do we plan on enabling it by default
in our Fedora yum package?
Comment 11 Paul Nasrat 2006-02-23 11:01:42 EST
Togami, the plan is to move this functionality into yum core rather than as a
plugin.
Comment 12 Paul Nasrat 2006-03-02 13:11:18 EST
Will be in yum 2.6 final and rawhide yum 2.5.3-3

Note You need to log in before you can comment on or make changes to this bug.