Bug 18186 - Can't switch keyboard mapping for Russian
Can't switch keyboard mapping for Russian
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 02:39 EDT by Vadim Zaliva
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 13:26:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Zaliva 2000-10-03 02:39:29 EDT
I had working russian keyboard setup under
XFree86-3.3.6 and Redhat-6.2. After upgrade
to RedHat 7 it does not work anymore.

Here is my Keyboard session from XF86Config:

Section "Keyboard"
      Protocol        "Standard"
      XkbKeycodes     "xfree86"
      XkbTypes        "complete"
      XkbCompat       "complete"
      XkbSymbols      "en_US(pc104)+ru-koi8+group(shift_toggle)"
      XkbGeometry     "microsoft(natural)"
EndSection

I use this file:

http://www.crocodile.org/lord/ru-koi8

which I've put to: /usr/lib/X11/xkb/symbols/ru-koi8.

It worked perfecly for me any some of my friends
before upgrade to 7.0.
Comment 1 Vadim Zaliva 2000-11-14 13:26:34 EST
I am original bug submitter.
Problem was in fact, that when I upgraded Redhat new X11
was installed. Xfree-4 have different cfg file format,
and old one was not successfuly converted to it (at least
'Keyboard' section was not preserved).

I've edited new cfg file according to new syntax and it works OK now.

Please note that in presence of /etc/X11/XFree86-4.cfg, old config
file /etc/X11/XFree86.cfg is ignored. Maybe it needs to be renamed
to avoid confusion: many people might try to edit old file, not
realizing it is not used. I did.

Comment 2 Mike A. Harris 2001-03-23 00:32:49 EST
The file has been renamed to avoid confusion IMHO.  XFree86 3.x uses
XF86Config as a config file.  XFree86 4.x uses XF86Config-4 if found
and XF86Config otherwise.  This is not a Red Hat modification, but is
standard XFree86 usage.  Since we ship both, we need to use 2 config
files.  The syntax of the file for XFree86 4 is totally different, so it
makes the most sense that the new version uses a new filename.  This
is only transitional however.  At some point in the future we will
stop shipping XFree86 3.x and only ship 4.x so the config file issues
wont matter much anymore.

I'm glad to see that you got your Russian keyboard map working though.
We will at some point be including some keyboard mapping enhancements
for Russian users as well.


Note You need to log in before you can comment on or make changes to this bug.