Bug 181866 - kernel-xen-hypervisor fails to boot
kernel-xen-hypervisor fails to boot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Juan Quintela
Brian Brock
:
Depends On:
Blocks: 179629
  Show dependency treegraph
 
Reported: 2006-02-17 05:35 EST by Andrew Parker
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-24 16:15:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of the kernel bug (68.89 KB, image/png)
2006-02-25 14:26 EST, Andrew Parker
no flags Details
Console log (12.17 KB, text/plain)
2006-03-14 18:47 EST, Andrew Parker
no flags Details

  None (edit)
Description Andrew Parker 2006-02-17 05:35:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Description of problem:
kernel-xen-hypervisor fails to boot on my SIS 741GX-M mobo with Athlon XP 2800+ CPU.

Previous versions with FC5T2 also fail

Version-Release number of selected component (if applicable):
kernel-xen-hypervisor-2.6.15-1.1955_FC5

How reproducible:
Always

Steps to Reproduce:
1.  Install kernel-xen-hypervisor
2.  reboot
3.
  

Actual Results:  Kernel dies as soon as it tries to reboot.  Text is way too fast to read anything, and logging to the serial console (console=tty console=ttyS0,38400n8) does not capture any output.

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:21:58 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Andrew Parker 2006-02-21 06:36:06 EST
I still get this with FC5T3.

I realise the info here is sparse, but if somebody could tell me how to get more
info, I'd be happy to help.
Comment 3 Chris Wright 2006-02-24 13:54:57 EST
Try booting with serial console support in hypervisor.  Something like the
following grub line:

 kernel /xen.gz com1=38400,8n1 console=com1,vga sync_console

That should show early Xen boot messages.
Comment 4 Stephen Tweedie 2006-02-24 16:01:30 EST
You can also add "console=ttyS0 console=tty" to the "module=kernel-*" line in
the grub config to get the kernel to route its own output over the same
hypervisor serial console driver.

Btw, the "ttywatch" rpm from fedora-extras[-development] is the best way I know
of to capture serial console on another machine.

Thanks!
Comment 5 Andrew Parker 2006-02-25 14:26:31 EST
Created attachment 125258 [details]
Screen shot of the kernel bug
Comment 6 Andrew Parker 2006-02-25 14:27:32 EST
I've been battering my head against this all morning, getting nowhere fast.  For
some reason, capturing the console output is extremely fickle.  The one and only
time that I managed to get anything was when it displayed the ASCII XEN 3.0.0
logo - and it stopped right after the URL.  I tried minicom, I tried ttywatch.I
even went out and bought another null modem cable thinking that mine may be
dodgy, but... FRUSTRATION!!!

Just as I was about to invite the damn thing out on a quail hunt, it ocurred to
me that with a sufficiently slow baud rate and sync_console enabled it would be
possible to read the output.  I've attached a screen shot of, what I am
assuming, is the relevant part of the problem (kernel BUG at
drivers/acpi/osl.c:509!).

For reference, the boot entry that I ended up using was:

title Fedora Core (2.6.15-1.1955_FC5hypervisor)
        root (hd0,0)
        kernel /boot/xen.gz-2.6.15-1.1955_FC5 com1=1200,8n1 console=com1,vga
sync_console
        module /boot/vmlinuz-2.6.15-1.1955_FC5hypervisor ro root=LABEL=/ rhgb
        module /boot/initrd-2.6.15-1.1955_FC5hypervisor.img
Comment 7 Andrew Parker 2006-03-06 18:46:27 EST
This problem persists with kernel-xen-hypervisor-2.6.15-1.2009.4.2_FC5 

kernel BUG at drivers/acpi/osl.c:509!
Comment 8 Stephen Tweedie 2006-03-09 17:29:20 EST
Are you saying serial console capture just doesn't work?  Adding
    com1=38400,8n1 sync_console
to the kernel=xen.gz... line AND
    console=ttyS0
to the module=kernel... line are both necessary in order to get this output from
the kernel.  Without the latter, you'll get hypervisor console output but not
kernel output.

Thanks!
Comment 9 Andrew Parker 2006-03-14 18:46:28 EST
To be quite honest, I'm not sure exactly where the problem was.  I spent an
extended period of time just trying to prove that the null-modem cable worked,
and never got that to a successful conclusion.  So it wasn't the kernel options
(although that obviously didn't help..)

Anyway, after trying a few more times, I've managed to get a dump.  The
interesting part is below, and is the same as the previously attached screen
shot, but at least this time it is searchable.  I'll also attach the complete
log too.

<snip>
PCI: setting up Xen PCI frontend stub
ACPI: Subsystem revision 20060127
ACPI: Access to PCI configuration space unavailable
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
------------[ cut here ]------------
kernel BUG at drivers/acpi/osl.c:509!
invalid opcode: 0000 [#1]
SMP
Modules linked in:
CPU:    0
EIP:    0061:[<c01ed34e>]    Not tainted VLI
EFLAGS: 00010246   (2.6.15-1.2009.4.2_FC5hypervisor #1)
<snip>
Comment 10 Andrew Parker 2006-03-14 18:47:58 EST
Created attachment 126132 [details]
Console log
Comment 12 Juan Quintela 2006-08-02 15:03:37 EDT
This bug looks like caused by:

 BUG_ON(!raw_pci_ops);

Since FC5 we have:
- enabled mmconfig
- enabled the go_any posibility
- fixed a bug on acpi code regarding to xen accessing ACPI.

I don't know if this bug has been fixed or no, xen code base has changed really
a lot since them :(

This is still use the kernel-xen-hypervisor names, i.e. it is previous to FC5.

If they can't reproduce, I think this is fixed.  Otherwise, we, really, really
need more info.  The BUG() against a recent kernel.

Later, Juan.
Comment 13 Will Woods 2007-03-24 16:14:24 EDT
This bug has been in NEEDINFO for about a year. Closing based on age and massive
updates in Xen. If it can be reproduced in FC6 or (better yet) rawhide or one of
the F7 test releases, please reopen it and we'll begin the hunt anew.

Note You need to log in before you can comment on or make changes to this bug.