Bug 1818691 - info icon displayed for none severity in slience list page
Summary: info icon displayed for none severity in slience list page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-30 06:25 UTC by hongyan li
Modified: 2020-07-13 17:24 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:24:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
Alert 'watch dog' has blue icon (175.93 KB, image/png)
2020-03-30 06:25 UTC, hongyan li
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4861 0 None closed Bug 1818691: Monitoring: Use blue circle "info" icon for `none` severity alerts 2021-01-06 06:05:36 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:24:33 UTC

Description hongyan li 2020-03-30 06:25:07 UTC
Created attachment 1674630 [details]
Alert 'watch dog' has blue icon

Description of problem:
severity is none for Watchdog, silence it, check in the Silences page, the icon is info

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-03-29-221016

How reproducible:
Always

Steps to Reproduce:
1. silence Watchdog alert which severity is none and check in Silences page

Actual results:
the icon is info for Watchdog silence

Expected results:
Should not have icon displayed for Watchdog silence

Comment 1 hongyan li 2020-03-30 07:02:24 UTC
it's better to have a consistent display for the severity of Watchdog alert on alert detail, alert list and silence list page. currently no icon on alert detail page and alert list page and blue icon on silence list page.

Comment 2 Andrew Pickering 2020-03-31 09:31:00 UTC
Opened PR for adding the blue circle icon everywhere that the severity "None" is displayed.

Comment 5 hongyan li 2020-04-03 01:33:59 UTC
Set up environment with payload: 4.5.0-0.ci-2020-04-02-224145
There is a consistent display for the severity of Watchdog alert on alert detail, alert list and silence list page

Comment 6 hongyan li 2020-04-03 01:35:27 UTC
All display info icon

Comment 8 errata-xmlrpc 2020-07-13 17:24:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.