Bug 181873 - mknod: Failed to create '/dev/ram0': already exists
Summary: mknod: Failed to create '/dev/ram0': already exists
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-17 12:24 UTC by Mark McLoughlin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 5.0.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 16:20:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mkinitrd-fix-ramdisk-device-nodes.patch (756 bytes, patch)
2006-02-17 12:24 UTC, Mark McLoughlin
no flags Details | Diff
mkinitrd-fix-find-command.patch (783 bytes, patch)
2006-02-17 12:29 UTC, Mark McLoughlin
no flags Details | Diff
mkinitrd-fix-ramdisk-device-nodes.patch (756 bytes, patch)
2006-02-17 12:30 UTC, Mark McLoughlin
no flags Details | Diff

Description Mark McLoughlin 2006-02-17 12:24:41 UTC
With mkinitrd CVS HEAD, I see the above warning (and for /dev/ram1 too)

What seems to be happening is that when you mount devpts, the ramdisk device
nodes (ram0 - ram15) automatically get created. I haven't been able to figure
out why ... :-)

Removing the two mknods seems to work fine

Patch also makes the /dev/ram link on the initramfs link to /dev/ram1 rather
than /dev/ram1 linking to non-existent /dev/ram

Comment 1 Mark McLoughlin 2006-02-17 12:24:41 UTC
Created attachment 124808 [details]
mkinitrd-fix-ramdisk-device-nodes.patch

Comment 2 Mark McLoughlin 2006-02-17 12:29:53 UTC
Created attachment 124810 [details]
mkinitrd-fix-find-command.patch

Fixed indentation

Comment 3 Mark McLoughlin 2006-02-17 12:30:57 UTC
Created attachment 124811 [details]
mkinitrd-fix-ramdisk-device-nodes.patch

Bah, getting confused between bugs

Comment 4 Peter Jones 2006-02-27 16:20:24 UTC
They get created by mkblkdevs.


Note You need to log in before you can comment on or make changes to this bug.