Bug 181907 - Radeon driver problems when using external LCD panel on Dell Inspiron 6000
Radeon driver problems when using external LCD panel on Dell Inspiron 6000
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-17 13:10 EST by Joshua M. Thompson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 13:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my xorg.conf file (3.19 KB, text/plain)
2006-02-17 13:10 EST, Joshua M. Thompson
no flags Details
Xorg.log file when booting on external display (53.39 KB, text/plain)
2006-02-17 13:11 EST, Joshua M. Thompson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5990 None None None Never

  None (edit)
Description Joshua M. Thompson 2006-02-17 13:10:33 EST
Created attachment 124825 [details]
my xorg.conf file
Comment 1 Joshua M. Thompson 2006-02-17 13:10:33 EST
Description of problem:

On my Dell Inspiron 6000, which has a built-in 1920x1200 display, if I plug in
an external LCD panel that only supports up to 1280x1024 the radeon driver does
not properly eliminate the 1920x1200 resolution from the mode list, thus making
the external monitor unusable until I hand-edit the xorg.conf file. This makes
it difficult to switch from using an external monitor at work and the built-in
display at home.

It appears the radeon driver is still using the specs for the internal display
even when set to use the external display.

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.5.7.3-3.2

How reproducible:

100% consistant

Steps to Reproduce:
1. Plug in external monitor
2. Set notebook to external display during boot (Fn + F8 for me)
  
Actual results:

X attempts to drive the external panel at 1920x1200

Expected results:

The 1920x1200 resolution should be eliminated as its out of the monitor's spec
and X should drop down to the next one in the list, 1280x1024.

Additional info:

This is also broken in FC4, but was working great when I first installed FC5t2.
However in the past two weeks or so one of the Xorg updates broke it again.
Comment 2 Joshua M. Thompson 2006-02-17 13:11:30 EST
Created attachment 124826 [details]
Xorg.log file when booting on external display
Comment 3 Giuseppe Castagna 2006-02-19 09:02:24 EST
I had quite a similar problem. I have an ATI X800 XL with DVI and VGA ourput and
an LCD monitor Viewsonic VG191 1280x1024. When I connected it only via the DVI
cable the monitor was not recognized (it was considered a CRT, gave a synch out
of range and the resolution dropped to 800x600), while if I connected only **or
also** the VGA, then the resolution was correctly set to 1280x1024. After
several tries (forcing panel size, etc, etc) I found that the problem went away
by using 
        Option      "MergedFB" "false"
since I noticed that when the VGA cable was connected the MergedFB was executed
instead of the monitor recognition (when VGA-cable is pluged).

I was going to fill a bug for the system-config-display, but I found your bug
report that looks quite similar. Let me know if my solution works.

Here what I use

xorg-x11-drv-ati-6.5.7.3-3.2
system-config-display-1.0.36-1

Please let me know if I have to fill a new bug report
 
Comment 4 Rahul Sundaram 2006-02-20 06:28:11 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 5 Joshua M. Thompson 2006-02-20 12:08:03 EST
Installed FC5t3 today, still happening.
Comment 6 Giuseppe Castagna 2006-02-21 04:01:52 EST
Well, same here. Obviously since my system was up-to-date with rawhide. Again,
is it the same bug (i.e. does the solution I suggest fix the problem) or should
I fill a different bug report?
Comment 7 Mike A. Harris 2006-02-21 06:12:23 EST
Please file a bug report in X.Org bugzilla at http://bugs.freedesktop.org
in the "xorg" component. Be sure to attach your current X server log,
config file and all details directly to the X.Org bugzilla so that the
upstream driver maintainers have as many details as possible in order
to diagnose the issue.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER" and awaiting upstream bug report
URL.
Comment 8 Joshua M. Thompson 2006-02-21 13:57:36 EST
https://bugs.freedesktop.org/show_bug.cgi?id=5990
Comment 9 Giuseppe Castagna 2006-02-21 14:34:33 EST
> Please file a bug report in X.Org bugzilla at http://bugs.freedesktop.org
>
> Once you've filed your bug report to X.Org, if you paste the new
> bug URL here

Here it is mine https://bugs.freedesktop.org/show_bug.cgi?id=5991 
Comment 10 Mike A. Harris 2006-06-27 13:10:56 EDT
Thanks guys, tracking upstream now...

Note You need to log in before you can comment on or make changes to this bug.