Bug 18191 - NET install with driver disk won't find SCSI disks
NET install with driver disk won't find SCSI disks
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 03:37 EDT by Alexandre Oliva
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 14:54:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2000-10-03 03:37:59 EDT
I've got a machine with an IDE CD-ROM and ZIP disk, but with 2 SCSI
hard-disks.

I've started a network (NFS) install with a driver disk (needed for the
network card).  When the installation gets to the point of partitioning the
disks, it will abort complaining it can't find any partitionable disks.

The problem is that the aic7xxx module isn't loaded, even though C-A-F3
says there was a hint to load it.  I know for sure the driver disk was
loaded, because the network card couldn't be found without it, and it was
found automatically when I booted up with `linux dd'.

The solution I've found was to C-A-F2, `modprobe aic7xxx', then proceed to
the installation.
Comment 1 Michael Fulbright 2000-10-05 18:08:47 EDT
What is your network card?
Comment 2 William Hester 2000-10-22 11:43:42 EDT
I had the same problem.  I was doing an NFS install.  I have an IDE-CDROM and a SCSI HD.  The Installer would forget to load my SCSI driver.
My network card (SMC EtherPower II) uses the epic100 driver from the driver disk.  My SCSI controller (Tekram DC-390U2W, symbios 53c895 chipset) uses the ncr53c8xx (or the sym53c8xx) driver, also from the driver disk.
I tried various combinations of "expert" and "dd" on the bootdisk's "pre-boot command-line" and using F2 to load the driver disk.  My network card driver loaded fine everytime, but I could never find my SCSI driver.
I also tried using the updates disk.  It didn't help me with this problem.  I simply did C-A-F2 and loaded the sym53c8xx driver manually with modprobe.  This worked okay for the install, but no initrd was created to load my SCSI driver on my HD nor the Installer created bootdisk.
Comment 3 Michael Fulbright 2000-11-07 14:55:56 EST
QA needs to be able to reproduce this issue.

What hardware do you have in your system so we can attempt to duplicate?
Comment 4 Brock Organ 2000-11-13 16:18:09 EST
verified this issue ... thanks for the report!
Comment 5 Erik Troan 2000-11-20 15:53:00 EST
This bug is fixed internally. You found a perfectly adequate workaround, and
this bug won't be in the next release.

Thanks for the report.
Comment 6 Aaron Brown 2000-12-13 12:41:39 EST
Verified this as resolved.

Note You need to log in before you can comment on or make changes to this bug.