Bug 181910 - 'rpm -e sendmail' deletes /etc/aliases.db, killing a working postfix
'rpm -e sendmail' deletes /etc/aliases.db, killing a working postfix
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-17 13:23 EST by Will Partain
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-14 09:40:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Partain 2006-02-17 13:23:26 EST
Description of problem:  At a working all-postfix site, I decided to get rid of
sendmail with 'rpm -e sendmail'.  Next thing, I found my postfix smtpd dying
instantly because it couldn't find /etc/aliases.db, *presumably* because the
sendmail removal got rid of it.

Version-Release number of selected component (if applicable): latest of everything


How reproducible:


Steps to Reproduce:
1. have a working postfix setup
2. rpm -e sendmail
3.
  
Actual results: as described above


Expected results:
I would not expect a postfix installation to be affected

Additional info:  I realize this *may* be because of non-std
local configuration (back from when the sendmail->postfix change was made). 
Could you give the rm script a quick check and make sure it is *very careful*
when doing that stuff?  Keep up the very fine work!
Comment 1 Thomas Woerner 2006-07-14 09:40:25 EDT
/etc/aliases.db is marked as ghost, therefore it does not remove the aliases.db
file. This is no sendmail erase problem.

Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.