Bug 1819136 - Custom Ansible modules not supported for the downstream documentation
Summary: Custom Ansible modules not supported for the downstream documentation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
low
Target Milestone: ---
: 4.4.0
Assignee: Maysa Macedo
QA Contact: weiwei jiang
URL:
Whiteboard:
Depends On: 1819132
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-31 09:55 UTC by Maysa Macedo
Modified: 2020-05-04 11:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1819132
Environment:
Last Closed: 2020-05-04 11:47:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3388 None closed Bug 1819136: Convert ansible module to openstackcli 2020-04-13 14:38:52 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:48:12 UTC

Description Maysa Macedo 2020-03-31 09:55:05 UTC
+++ This bug was initially created as a clone of Bug #1819132 +++

Description of problem:

The current OpenStack UPI support is relying on custom Ansible modules to perform operations not supported by Ansible.
However, the downstream documentation of this work would needed to link the Github repository containing those custom modules,
which is not permitted by support.
As there's no more time to rely on building RPM, a conversion of those modules to openstackcli for the playbooks is needed.

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 weiwei jiang 2020-04-14 09:20:08 UTC
Checked with 4.4.0-0.nightly-2020-04-13-113747, and work well, so moved to verified.

Comment 5 errata-xmlrpc 2020-05-04 11:47:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.