Bug 1819177 - python-asteval fails to build with Python 3.9: Test failures
Summary: python-asteval fails to build with Python 3.9: Test failures
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-asteval
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1842111 (view as bug list)
Depends On:
Blocks: F33FTBFS F33FailsToInstall F33BetaFreezeException PYTHON39
TreeView+ depends on / blocked
 
Reported: 2020-03-31 12:07 UTC by Miro Hrončok
Modified: 2020-09-14 23:43 UTC (History)
6 users (show)

Fixed In Version: python-asteval-0.9.18-5.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-14 23:43:43 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github newville asteval issues 69 None closed Python 3.9 2020-09-14 14:27:17 UTC

Description Miro Hrončok 2020-03-31 12:07:37 UTC
python-asteval fails to build with Python 3.9.0a5.

___________________________ TestEval.test_dict_index ___________________________

self = <test_asteval.TestEval testMethod=test_dict_index>

    def test_dict_index(self):
        """dictionary indexing"""
        self.interp("a_dict = {'a': 1, 'b': 2, 'c': 3, 'd': 4}")
>       self.istrue("a_dict['a'] == 1")

tests/test_asteval.py:141: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
tests/test_asteval.py:105: in istrue
    return self.assertTrue(val)
E   AssertionError: False is not true
___________________________ TestEval.test_list_index ___________________________

self = <test_asteval.TestEval testMethod=test_list_index>

    def test_list_index(self):
        """list indexing"""
        self.interp("a_list = ['a', 'b', 'c', 'd', 'o']")
>       self.istrue("a_list[0] == 'a'")

tests/test_asteval.py:147: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
tests/test_asteval.py:105: in istrue
    return self.assertTrue(val)
E   AssertionError: False is not true
____________________________ TestEval.test_minimal _____________________________

self = <test_asteval.TestEval testMethod=test_minimal>

    def test_minimal(self):
        aeval = Interpreter(builtins_readonly=True, minimal=True)
        aeval("a_dict = {'a': 1, 'b': 2, 'c': 3, 'd': 4}")
>       self.assertTrue(aeval("a_dict['a'] == 1"))
E       AssertionError: False is not true

tests/test_asteval.py:1024: AssertionError
______________________________ TestEval.test_repr ______________________________

self = <test_asteval.TestEval testMethod=test_repr>

    def test_repr(self):
        """repr of dict, list"""
        self.interp("x = {'a': 1, 'b': 2, 'c': 3}")
        self.interp("y = ['a', 'b', 'c']")
        self.interp("rep_x = repr(x['a'])")
        self.interp("rep_y = repr(y)")
        self.interp("rep_y , rep_x")
        self.interp("repr(None)")
>       self.isvalue("rep_x", "1")

tests/test_asteval.py:360: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

self = <test_asteval.TestEval testMethod=test_repr>, sym = 'rep_x', val = '1'

    def isvalue(self, sym, val):
        """assert that a symboltable symbol has a particular value"""
        tval = self.interp.symtable[sym]
        if HAS_NUMPY and isinstance(val, np.ndarray):
            assert_allclose(tval, val, rtol=0.01)
        else:
>           assert(tval == val)
E           AssertionError: assert 'None' == '1'
E             - None
E             + 1

tests/test_asteval.py:91: AssertionError
__________________________ TestEval.test_string_index __________________________

self = <test_asteval.TestEval testMethod=test_string_index>

    def test_string_index(self):
        """string indexing"""
        self.interp("a_string = 'hello world'")
>       self.istrue("a_string[0] == 'h'")

tests/test_asteval.py:160: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
tests/test_asteval.py:105: in istrue
    return self.assertTrue(val)
E   AssertionError: False is not true
__________________________ TestEval.test_tuple_index ___________________________

self = <test_asteval.TestEval testMethod=test_tuple_index>

    def test_tuple_index(self):
        """tuple indexing"""
        self.interp("a_tuple = (5, 'a', 'x')")
>       self.istrue("a_tuple[0] == 5")

tests/test_asteval.py:154: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
tests/test_asteval.py:105: in istrue
    return self.assertTrue(val)
E   AssertionError: False is not true
===================== 6 failed, 52 passed in 1.17 seconds ======================

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01324205-python-asteval/

For all our attempts to build python-asteval with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-asteval/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Fabian Affolter 2020-04-03 08:07:50 UTC
https://github.com/newville/asteval/issues/69

Comment 2 Miro Hrončok 2020-05-25 13:01:50 UTC
This comment is mass posted to all bugs blocking the Python 3.9 tracker, sorry if it is not 100 % relevant. When in doubt, please ask.


The Python 3.9 rebuild is in progress in a Koji side tag.

If you fix this bug, please don't rebuild the package in regular rawhide, but do it in the side tag with:

    $ fedpkg build --target=f33-python

The rebuild is progressing slowly and it is possible this package won't have all the required build dependencies yet. If that's the case, please just leave the fix committed and pushed and we will eventually rebuild it for you.

You are not asked to go and try rebuild all the missing dependencies yourself. If you know there is a bootstrap loop in the dependencies, let me know and we can untangle it together.

If you want to test your fix or reproduce the failure, you can still use the Copr repo mentioned in the initial comment of this bug: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Comment 3 Miro Hrončok 2020-05-29 07:11:45 UTC
Python 3.9 update: The f33-python side tag is currently being merged.

New builds in f33-python are no longer possible, but python3 is not yet updated to Python 3.9 in rawhide. You can check when Python is Python 3.9 with:

    $ koji wait-repo f33-build --build python3.9-3.9.0~b1-3.fc3

And build the packages normally after that.

Comment 4 Tomáš Hrnčiar 2020-06-09 10:11:05 UTC
*** Bug 1842111 has been marked as a duplicate of this bug. ***

Comment 5 Igor Raits 2020-06-16 18:46:39 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Ben Cotton 2020-08-11 13:16:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 7 Miro Hrončok 2020-08-22 10:30:53 UTC
Hello. This comment is mass posted to all 16 bugzillas for packages that failed to rebuild with Python 3.9 (and, in most cases, also fail to install on Fedora 33 and 34). Apologies if some of the suggestions or questions don't apply 100%.

Fedora 33 Beta Freeze starts next week on Tuesday, 2020-08-25. I haven't spammed this bugzilla because it is in ASSIGNED, or I've seen upstream has been notified.

Please consider what to do here. Is this failure critical? For example, can a test be temporarily skipped to make this package build? Is it possible to fix or workaround the failure before Fedora 33 Beta? Or before Fedora 33 Final? If not, would it make sense to retire the package (even temporarily) before the release to unblock updates from Fedora 31 or Fedora 32?

In case you need any assistance with a Python-related problem with the build, don't hesitate to let me know and I'll try to have a look.

Thank you!

Comment 8 Miro Hrončok 2020-08-25 20:58:55 UTC
Thanks for the workaround, Fabian. Could you please create the Fedora 33 update in bodhi as well?

Comment 9 Fedora Update System 2020-08-26 06:05:13 UTC
FEDORA-2020-95fa24f451 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-95fa24f451

Comment 10 Fedora Update System 2020-08-26 17:06:59 UTC
FEDORA-2020-95fa24f451 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-95fa24f451`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-95fa24f451

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Blocker Bugs Application 2020-09-10 16:51:43 UTC
Proposed as a Freeze Exception for 33-beta by Fedora user churchyard using the blocker tracking app because:

 The package does not install without the proposed update.

Comment 12 Kamil Páral 2020-09-14 14:27:47 UTC
Accepted as a Beta freeze exception:
https://pagure.io/fedora-qa/blocker-review/issue/78

Comment 13 Fedora Update System 2020-09-14 23:43:43 UTC
FEDORA-2020-95fa24f451 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.