Bug 1819472 - cluster-etcd-operator: CVO is overwriting cert configmaps with invalid data [NEEDINFO]
Summary: cluster-etcd-operator: CVO is overwriting cert configmaps with invalid data
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks: 1820748
TreeView+ depends on / blocked
 
Reported: 2020-03-31 23:14 UTC by Sam Batschelet
Modified: 2020-07-13 17:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: CVO was overwriting certificates in configmap every 10 mins Consequence: Overhead with sync every 10 mins Fix: Create certificates in configmap only once. Result: No overhead with syching ca data every 10 mins resulting a stabler system and improved performance.
Clone Of:
: 1820748 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:24:27 UTC
Target Upstream Version:
geliu: needinfo? (sbatsche)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 289 None closed Bug 1819472: manifests: update CVO managed configmaps to create-only 2020-06-30 18:58:44 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:24:49 UTC

Description Sam Batschelet 2020-03-31 23:14:46 UTC
Description of problem: configmaps for the etcd-ca-bundle is populated with a default value. The result is CVO will rewrite the invalid config map data "stub" and cause other controllers in the operator to sync adding overhead to the cluster and in some cases could result in failed client calls to etcd by the operator. These calls could result in invalid event data. For example if a call to status failed we would consider the member unhealthy.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: CVO to create the configmap resource once and not overwrite it.


Additional info:

Comment 6 errata-xmlrpc 2020-07-13 17:24:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.