Bug 1819486 (CVE-2019-11254) - CVE-2019-11254 kubernetes: Denial of service in API server via crafted YAML payloads by authorized users
Summary: CVE-2019-11254 kubernetes: Denial of service in API server via crafted YAML p...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-11254
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1820449 1820450 1820452 1820453 1820454 1820458 1820459
Blocks: 1819487
TreeView+ depends on / blocked
 
Reported: 2020-04-01 00:20 UTC by Sam Fowler
Modified: 2020-07-13 17:23 UTC (History)
19 users (show)

Fixed In Version: kubernetes 1.17.3, kubernetes 1.16.7, kubernetes 1.15.10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-18 23:20:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:2412 None None None 2020-07-13 17:23:14 UTC
Red Hat Product Errata RHSA-2020:2413 None None None 2020-07-13 16:45:00 UTC
Red Hat Product Errata RHSA-2020:2479 None None None 2020-06-18 21:11:30 UTC

Description Sam Fowler 2020-04-01 00:20:34 UTC
A denial of service vulnerability was found in the kube-apiserver, allowing authorized users sending malicious YAML payloads to cause kube-apiserver to consume excessive CPU cycles while parsing YAML.


Upstream Issue:

https://github.com/kubernetes/kubernetes/issues/89535

Comment 2 Sam Fowler 2020-04-01 00:24:26 UTC
Mitigation:

Prevent unauthenticated or unauthorized access to the API server

Comment 5 Sam Fowler 2020-04-01 06:44:27 UTC
Go yaml fix:

https://github.com/go-yaml/yaml/pull/555

Comment 10 Sam Fowler 2020-05-12 05:22:30 UTC
- openshift4/ose-openshift-state-metrics-rhel7 does not accept YAML payloads
- openshift4/ose-k8s-prometheus-adapter only exposes a read-only API

Comment 11 Sam Fowler 2020-05-12 05:22:33 UTC
Statement:

The upstream Kubernetes fix for this vulnerability is to update the version of the Go dependency, gopkg.in/yaml.v2. This issue affects OpenShift Container Platform components that use versions before 2.2.8 of gopkg.in/yaml.v2 and accept YAML payloads.

Comment 12 errata-xmlrpc 2020-06-18 21:11:28 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 3.11

Via RHSA-2020:2479 https://access.redhat.com/errata/RHSA-2020:2479

Comment 13 Product Security DevOps Team 2020-06-18 23:20:28 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-11254

Comment 14 errata-xmlrpc 2020-07-13 16:44:58 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 4.5

Via RHSA-2020:2413 https://access.redhat.com/errata/RHSA-2020:2413

Comment 15 errata-xmlrpc 2020-07-13 17:23:12 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 4.5

Via RHSA-2020:2412 https://access.redhat.com/errata/RHSA-2020:2412


Note You need to log in before you can comment on or make changes to this bug.